Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#37493 - [libreoffice-kde4] KSambaShare: Could not find smb.conf

Attached to Project: Arch Linux
Opened by Patryk Rzucidlo (PTKDev) - Friday, 25 October 2013, 19:18 GMT
Last edited by Andreas Radke (AndyRTR) - Thursday, 07 November 2013, 16:06 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Andreas Radke (AndyRTR)
Bartłomiej Piotrowski (Barthalion)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
I write document and libreoffice-writer crashed on save :(

Additional info:
* package version(s): 4.1.2.3
* config and/or log files etc.


Steps to reproduce:
- Write Document
- File ---> Save
- 1-2 second and crash
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Thursday, 07 November 2013, 16:06 GMT
Reason for closing:  Upstream
Comment by Andreas Radke (AndyRTR) - Saturday, 26 October 2013, 08:25 GMT
Please try without Libreoffice-kde integration.
Comment by hopimet (hopimet) - Saturday, 26 October 2013, 13:21 GMT
I had the same problem with writer or calc on my desktop with kde for a few weeks. It seems that removing libreoffice-kde4 solved it. For information this bug never occurred on my laptop with openbox which suggests that it is indeed related to the libreoffice-kde4 integration plugin.
Many thanks to Andreas.
Comment by jk (jk) - Thursday, 07 November 2013, 15:18 GMT
same problem here.
removing libreoffice-kde doesn't reproduce crasher.
since i've lost my work, i'd ask to write a security news to prevent users using libreoffice-kde until the bug is fixed

attached backtrace
Comment by Andreas Radke (AndyRTR) - Thursday, 07 November 2013, 15:34 GMT
Check for existing upstream reports or file a new one to the LibO tracker.

And no, such thing won't go to the Arch news items. It's just an annoying bug not a distribution wide major change.
Comment by jk (jk) - Thursday, 07 November 2013, 15:59 GMT
upstream bug: https://bugs.freedesktop.org/show_bug.cgi?id=59398as

as alternative, i can suggest installing libreoffice-gnome and oxygen-gtk for theming integration.
unfortunatly, dbus menu export doesn't work, libdbusmenu-gtk2 is missing in [community]
Comment by Andreas Radke (AndyRTR) - Thursday, 07 November 2013, 16:06 GMT
CC'ed to the report. Closing the downstream bug now. We can't do anything here.

Loading...