Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#37479 - [libglade] libglade-convert has a bad interpreter line

Attached to Project: Arch Linux
Opened by Muflone (muflone) - Friday, 25 October 2013, 08:11 GMT
Last edited by Jan de Groot (JGC) - Monday, 28 October 2013, 14:56 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

The file /usr/bin/libglade-convert has a wrong interpreter line:
#!python2
which produces the following error:
bash: /usr/bin/libglade-convert: python2: bad interpreter: No such file or directory

The interpreter line should instead be:
#!/usr/bin/env python2

Additional info:
package extra/libglade 2.6.4-4

Steps to reproduce:

Just to execute libglade-convert and the error will be shown.
This task depends upon

Closed by  Jan de Groot (JGC)
Monday, 28 October 2013, 14:56 GMT
Reason for closing:  Fixed
Comment by Muflone (muflone) - Friday, 25 October 2013, 08:12 GMT
Attached patch to fix the interpreter line

Loading...