Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#37465 - acpi issues with nvidia

Attached to Project: Arch Linux
Opened by Amitav (amitavmohanty01) - Thursday, 24 October 2013, 08:48 GMT
Last edited by Jan de Groot (JGC) - Monday, 28 October 2013, 13:46 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
NVidia is having issues with ACPI.

Looking at journalctl I can see the following lines.

Oct 24 12:01:18 TSS-ARCH kernel: ACPI Warning: \_SB_.PCI0.PEG0.VID_._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20130517/nsarguments-95)
Oct 24 12:01:18 TSS-ARCH kernel: ACPI Warning: \_SB_.PCI0.PEG0.VID_._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20130517/nsarguments-95)
Oct 24 12:01:18 TSS-ARCH kernel: ACPI Warning: \_SB_.PCI0.PEG0.VID_._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20130517/nsarguments-95)
Oct 24 12:01:18 TSS-ARCH kernel: ACPI Warning: \_SB_.PCI0.PEG0.VID_._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20130517/nsarguments-95)
Oct 24 12:01:18 TSS-ARCH kernel: ACPI Warning: \_SB_.PCI0.PEG0.VID_._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20130517/nsarguments-95)
Oct 24 12:01:18 TSS-ARCH kernel: ACPI Warning: \_SB_.PCI0.PEG0.VID_._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20130517/nsarguments-95)
Oct 24 12:01:18 TSS-ARCH kernel: ACPI Warning: \_SB_.PCI0.PEG0.VID_._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20130517/nsarguments-95)
Oct 24 12:01:18 TSS-ARCH kernel: ACPI Warning: \_SB_.PCI0.PEG0.VID_._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20130517/nsarguments-95)
Oct 24 12:01:18 TSS-ARCH kernel: ACPI Warning: \_SB_.PCI0.PEG0.VID_._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20130517/nsarguments-95)

Desktop effects in KDE which were working so far seem to be having issues now. "It says OpenGL has crashed KWin in the past. This was most likely due to a driver bug." I am not very sure if the two are related or not.

Additional info:
* package version(s)
nvidia 325.15-10
linux 3.11.5-1, 3.11.6-1
kde 4.11.2
This task depends upon

Closed by  Jan de Groot (JGC)
Monday, 28 October 2013, 13:46 GMT
Reason for closing:  Fixed
Additional comments about closing:  upower bug fixed. Nvidia driver crashes or broken bioses with bad ACPI tables can't be fixed by us.
Comment by Jan de Groot (JGC) - Thursday, 24 October 2013, 10:33 GMT
These ACPI warnings are unrelated, they're caused by bad ACPI tables provided by your mainboard BIOS.
Comment by Amitav (amitavmohanty01) - Thursday, 24 October 2013, 10:47 GMT
KDE's battery widget is showing 0% while the charge is 100%.
acpi -b says 100% charged.

If the warnings are related to bad ACPI tables, is it possible that a BIOS upgrade will fix it ?
Comment by Jan de Groot (JGC) - Thursday, 24 October 2013, 10:54 GMT
Warnings about bad ACPI tables can only be fixed by your mainboard vendor, should be fixed with a BIOS update. Probably they will not fix it for you, as they don't support linux and "windows works fine".

Anyways, your bugreport is full of unrelated things: crashes due to nvidia driver, ACPI errors in dmesg and now you're reporting 0% charge for your battery in KDE.

Nvidia is something we can't fix, it's a binary blob, so you should report issues upstream at nvidia. BIOS errors can't be fixed by us either, so you have to contact your mainboard vendor if you want to get rid of those.

As for your battery: http://cgit.freedesktop.org/upower/commit/?h=0.9&id=b8fe9902f3c6c50ca6a23e24fcea99582beebc65

It's very likely this applies to your situation. We'll update upower soon and take these post-release commits in the package also. The linked commit probably fixes your battery problem.
Comment by Amitav (amitavmohanty01) - Thursday, 24 October 2013, 12:34 GMT
Yes, I do not disagree that there are unrelated issues on this report. Thank you for pointing out the upower issue. I think that is the issue because when the battery drops to 90%, the widget shows correctly.
Comment by Amitav (amitavmohanty01) - Monday, 28 October 2013, 08:30 GMT
kernel: ACPI: Requesting acpi_cpufreq
kernel: pps_core: LinuxPPS API ver. 1 registered
kernel: pps_core: Software ver. 5.3.6 - Copyright 2005-2007 Rodolfo Giometti <giometti@linux.it>
kernel: ACPI Warning: 0x0000000000000428-0x000000000000042f SystemIO conflicts with Region \PMIO 1 (20130517/utaddress-251)
kernel: ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
kernel: ACPI Warning: 0x0000000000000540-0x000000000000054f SystemIO conflicts with Region \GPIO 1 (20130517/utaddress-251)
kernel: ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
kernel: ACPI Warning: 0x0000000000000530-0x000000000000053f SystemIO conflicts with Region \GPIO 1 (20130517/utaddress-251)
kernel: ACPI Warning: 0x0000000000000530-0x000000000000053f SystemIO conflicts with Region \_SB_.PCI0.PEG0.VID_.GPSP 2 (20130517/utaddress-251)
kernel: ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
kernel: ACPI Warning: 0x0000000000000500-0x000000000000052f SystemIO conflicts with Region \GPIO 1 (20130517/utaddress-251)
kernel: ACPI Warning: 0x0000000000000500-0x000000000000052f SystemIO conflicts with Region \_SB_.PCI0.PEG0.VID_.GPSP 2 (20130517/utaddress-251)
kernel: ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
kernel: lpc_ich: Resource conflict(s) found affecting gpio_ich
kernel: PTP clock support registered

These warnings are a little above the warnings I posted earlier. These might hint a little more about the issue. Btw, how can I find ACPI drivers for my devices ?

Loading...