Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#37289 - [cinnamon] Cannot launch cinnamon-settings - missing image module

Attached to Project: Community Packages
Opened by Robert Orzanna (orschiro) - Friday, 11 October 2013, 09:23 GMT
Last edited by Balló György (City-busz) - Monday, 04 November 2013, 00:43 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Alexandre Filgueira (faidoc)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

When I try to run `cinnamon-settings` it fails with the following message:

[orschiro@thinkpad ~]$ cinnamon-settings
No module named Image
However, I seem to have installed all relevant packages:
:: python2-imaging and python2-pillow are in conflict (python-imaging). Remove python2-pillow? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: cinnamon: requires python2-pillow


Additional info:
* package version(s)
* config and/or log files etc.

cinnamon 2.0.2-1
cinnamon-control-center 2.0.2-1

This task depends upon

Closed by  Balló György (City-busz)
Monday, 04 November 2013, 00:43 GMT
Reason for closing:  Works for me
Comment by Alexandre Filgueira (faidoc) - Friday, 11 October 2013, 20:05 GMT
Try reinstalling python2-pillow
Comment by Robert Orzanna (orschiro) - Friday, 11 October 2013, 20:17 GMT
I tried that already:

[orschiro@thinkpad ~]$ sudo pacman -S python2-pillow
[sudo] password for orschiro:
warning: python2-pillow-2.2.1-1 is up to date -- reinstalling
resolving dependencies...
looking for inter-conflicts...

Packages (1): python2-pillow-2.2.1-1

Total Installed Size: 1.56 MiB
Net Upgrade Size: 0.00 MiB

:: Proceed with installation? [Y/n]
(1/1) checking keys in keyring [######################] 100%
(1/1) checking package integrity [######################] 100%
(1/1) loading package files [######################] 100%
(1/1) checking for file conflicts [######################] 100%
(1/1) checking available disk space [######################] 100%
(1/1) reinstalling python2-pillow [######################] 100%
[orschiro@thinkpad ~]$ cinnamon-settings
No module named Image
Comment by Alexandre Filgueira (faidoc) - Friday, 11 October 2013, 20:29 GMT
Is your /usr/lib/cinnamon-settings/cinnamon-settings.py header calling python or python2? It should be calling python2, otherwise it would be searching for python-pillow instead of python2-pillow version. The current package should change it by default to python2 as it is right now.

If you have python2 in the header, check also if you can import Image in a python2 console: python2 -> from PIL import Image
Comment by Robert Orzanna (orschiro) - Friday, 11 October 2013, 20:35 GMT
No errors:

[orschiro@thinkpad ~]$ cat /usr/lib/cinnamon-settings/cinnamon-settings.py | head
#!/usr/bin/python2

[orschiro@thinkpad ~]$ python2
Python 2.7.5 (default, Sep 6 2013, 09:55:21)
[GCC 4.8.1 20130725 (prerelease)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> from PIL import Image
Comment by Robert Orzanna (orschiro) - Sunday, 13 October 2013, 11:42 GMT
If I use python2-imaging instead of python2-pillow, then I can launch cinnamon-settings:

[orschiro@thinkpad ~]$ cinnamon-settings
/usr/lib/python2.7/site-packages/gi/types.py:226: RuntimeWarning: Mixin class XletSettingsWidgets.BaseWidget is an old style class, please update this to derive from "object".
RuntimeWarning)
/usr/lib/cinnamon-settings/modules/cs_user.py:112: Warning: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
file_icon = Gio.FileIcon().new(file)
Could not find bluetooth module; is the cinnamon-control-center package installed?
__init__ took 8932.928 ms
Comment by Alexandre Filgueira (faidoc) - Sunday, 13 October 2013, 14:45 GMT
Hmmmm that is weird... Check /usr/lib/cinnamon-settings/bin/imtools.py to see what are you importing. It should say "from PIL import Image"
Comment by Robert Orzanna (orschiro) - Sunday, 13 October 2013, 15:15 GMT
Yes it does:

[orschiro@thinkpad ~]$ cat /usr/lib/cinnamon-settings/bin/imtools.py | grep "from PIL"
from PIL import Image
from PIL import ImageDraw
from PIL import ImageEnhance
from PIL import ImageOps, ImageChops, ImageFilter
Comment by Robert Orzanna (orschiro) - Monday, 28 October 2013, 13:51 GMT
The bug is still persistent with cinnamon-settings-daemon 2.0.5-1.
Comment by Robert Orzanna (orschiro) - Friday, 01 November 2013, 15:44 GMT
Upstream commented that you should change the dependency to python2-imaging.

See: https://github.com/linuxmint/Cinnamon/issues/2495#issuecomment-27574724

What do you think?
Comment by Alexandre Filgueira (faidoc) - Saturday, 02 November 2013, 01:44 GMT
python2-imaging was replaced by python2-pillow, which provides python2-imaging so it shouldn't be a problem. I know that python2-imaging is still available on the repos, but I will have to consult about this. I can't reproduce your error using python2-pillow
Comment by Balló György (City-busz) - Saturday, 02 November 2013, 23:27 GMT
I can't reproduce it either on my systems. I think that something should be wrong on your system, because nobody else experienced this problem.
Comment by Robert Orzanna (orschiro) - Sunday, 03 November 2013, 16:58 GMT
I am afraid you are right. What do you recommend me to try?

Reinstalling the packages, as already reported above, does not resolve it.
Comment by Balló György (City-busz) - Sunday, 03 November 2013, 18:18 GMT
You could try to reinstall all packages on your system. To do this, make sure that no third party repositories enabled in pacman.conf, then run the following command:
# pacman -S $(pacman -Qq | grep -v "$(pacman -Qmq)")
Comment by Balló György (City-busz) - Sunday, 03 November 2013, 21:08 GMT
I'm closing this task now, but feel free to ask help on the forum.

Loading...