Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#37258 - After recent update from [2013-10-07], latest gtk2 and gtk3 are screwing UI appearance

Attached to Project: Arch Linux
Opened by Daniel (8472) - Tuesday, 08 October 2013, 18:10 GMT
Last edited by Jan Steffens (heftig) - Wednesday, 09 October 2013, 17:42 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Jan Steffens (heftig)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:
- After recent update from [2013-10-07], gtk2 and gtk3 were updated to gtk2-2.24.21-2 & gtk3-3.10.0-2, appearance is broken.
- All recent upgrades of everything installed, always.
- Using OpenBox.
- Both of these packages have some font or appearance bug, causing, much more space is taken by any app. objects (menu font is changed, more space around menu options is consumed, also any other objects take more space - e.g. in Thunderbird, content of mailbox uses some bigger font and consumes more empty space around each line, the same with e.g. Firefox bookmarks).
- Have tested in on normal workstation, and a VM in VirtualBox (both having Arch), both of them affected the same way.
- Attaching screenshots (both unaffected and affected on one image in file gtk_v2&v3_bug.jpg - with apps e.g. roxterm and mousepad showing differences).

Recent not affected versions (attachment not_affected-gtk_v2&v3.jpg):
gtk2-2.24.20-1
gtk3-3.8.4-1

Newly affected versions (attachment affected-gtk_v2&v3.jpg):
gtk2-2.24.21-2
gtk3-3.10.0-2


Steps to reproduce:
OpenBox at least (Unknown, whether it happens with other WM - ain't using any other).
Install the recent versions of gtk2-2.24.21-2 & gtk3-3.10.0-2, and you'll see the screwed appearance as I got (affected-gtk_v2&v3.jpg).

Downgrading to previous gtk2-2.24.20-1 & gtk3-3.8.4-1 will restore the desired state.
This task depends upon

Closed by  Jan Steffens (heftig)
Wednesday, 09 October 2013, 17:42 GMT
Reason for closing:  Not a bug
Comment by Hellracer (hellracer) - Tuesday, 08 October 2013, 19:34 GMT
I'm not sure but could be corresponding: since last update from 2013-10-07 Java Applications using eclipse swt are broken. I apped log from jameica(AUR).
Comment by Jan de Groot (JGC) - Tuesday, 08 October 2013, 21:23 GMT
You should get an updated theme. Older themes usually break when GTK is upgraded.
Comment by Daniel (8472) - Wednesday, 09 October 2013, 06:56 GMT
@Jan de Groot (JGC): I'm using OpenBox with my theme for years already, and it never got broken like this ever before (while both gtk2 & gtk3 have been upgraded many times during these years - as I've checked the changelog).
Comment by AdamW (skanky) - Wednesday, 09 October 2013, 08:23 GMT
I saw a similar effect in Firefox using Pentadactyl, but no DE. The effect was ffx theme irrelevant.
I solved it by editing /usr/share/gtk-2.0/gtkrc. The last line that specifies the font is set to 11 and I changed it to 9.
Not sure what it was before. Obviously this won't survive an update and I'll move it to a user config file at some point.

This may be what's causing the issue. I haven't run a gtk3 application yet, but I notice its font is set the same.
Comment by Jan de Groot (JGC) - Wednesday, 09 October 2013, 11:01 GMT
It seems these default settings were added in the last commit done 9 days ago.

Jan, can you explain why you added additional default settings?
Comment by Jan Steffens (heftig) - Wednesday, 09 October 2013, 11:32 GMT
This is not a bug, simply a change in defaults. It was motivated by the need to address the removal of the gtk-fallback-icon-theme setting. Together with this came move of the packaged config files to /usr/share, making backups in /etc obsolete, as well as an unification of default theme settings to those of the GNOME desktop environment, which the GTK development targets.

If you want the previous behavior for GTK3, add a file /etc/gtk-3.0/settings.ini with the following content:

[Settings]
gtk-theme-name = Raleigh
gtk-font-name = Sans 9

And for GTK2, add a file /etc/gtk-2.0/gtkrc with the following content:

gtk-theme-name = "Raleigh"
gtk-font-name = "Sans 9"

These files, unlike the ones in /usr/share, won't be overwritten on upgrade.
Comment by Daniel (8472) - Wednesday, 09 October 2013, 15:09 GMT
Perfect, thanks a lot, these gtk-theme-name and gtk-font-name solved the problem.

@Jan Steffens (heftig): just out of curiosity, what are the new default values of these pls?

I believe you can close it afterwards, as explanation and a solution has been provided.
Comment by Jan Steffens (heftig) - Wednesday, 09 October 2013, 17:42 GMT
The default values we define are in the files in /usr/share/gtk-{2,3}.0 .

They go with the documented default themes "gnome-themes-standard" and "gnome-icon-theme".

Loading...