Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#37226 - [avant-window-navigator] AWN crashes on startup

Attached to Project: Community Packages
Opened by Eugene Lipchansky (NSky) - Monday, 07 October 2013, 16:16 GMT
Last edited by György Balló (City-busz) - Wednesday, 09 October 2013, 15:20 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To György Balló (City-busz)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 11
Private No

Details

Description:
AWN stopped working after the lates system update (update to GNOME 3.10 has happened)

Additional info:
avant-window-navigator 0.4.0.13

$ avant-window-navigator
** (avant-window-navigator:9611): CRITICAL **: desktop_agnostic_config_schema_get_metadata_option: assertion 'self != NULL' failed
** (avant-window-navigator:9611): CRITICAL **: desktop_agnostic_config_schema_get_metadata_option: assertion 'self != NULL' failed

Segmentation fault (core dumped)


Steps to reproduce:
Upgrage system and run AWN
This task depends upon

Closed by  György Balló (City-busz)
Wednesday, 09 October 2013, 15:20 GMT
Reason for closing:  Won't fix
Additional comments about closing:  avant-window-navigator has been dropped into AUR.
Comment by Joe (kfmd) - Monday, 07 October 2013, 17:11 GMT
I can confirm this.

Package version: avant-window-navigator-0.4.0-13
Kernel: 3.11.4-1-ARCH

Backtrace:
#0 0xb7dff310 in ?? () from /usr/lib/libdesktop-agnostic-cfg.so.0
#1 0xb7e017ec in ?? () from /usr/lib/libdesktop-agnostic-cfg.so.0
#2 0xb771cd18 in ?? () from /usr/lib/libgobject-2.0.so.0
#3 0xb771ed17 in g_object_new_valist () from /usr/lib/libgobject-2.0.so.0
#4 0xb771ef70 in g_object_new () from /usr/lib/libgobject-2.0.so.0
#5 0xb7dff7ef in desktop_agnostic_config_client_construct_for_instance ()
from /usr/lib/libdesktop-agnostic-cfg.so.0
#6 0xb7e01b54 in desktop_agnostic_config_client_new_for_instance ()
from /usr/lib/libdesktop-agnostic-cfg.so.0
#7 0xb7e3ae72 in awn_config_get_default () from /usr/lib/libawn.so.1
#8 0x08062e51 in ?? ()
#9 0x0804f19a in ?? ()
#10 0xb7739a63 in g_type_create_instance () from /usr/lib/libgobject-2.0.so.0
#11 0xb771c87e in ?? () from /usr/lib/libgobject-2.0.so.0
#12 0xb771e871 in g_object_newv () from /usr/lib/libgobject-2.0.so.0
#13 0xb771ef90 in g_object_new () from /usr/lib/libgobject-2.0.so.0
#14 0x0804f358 in ?? ()
#15 0x0804eaa7 in ?? ()
#16 0xb740c9d3 in __libc_start_main () from /usr/lib/libc.so.6
#17 0x0804ebf9 in ?? ()
Comment by Bruno Guerreiro (American_Jesus) - Monday, 07 October 2013, 17:18 GMT
Here too, AWN stopped working after upgrading to GNOME 3.10
Comment by Ricardo Dantas (licensed) - Monday, 07 October 2013, 20:53 GMT
Same problem here after upgrade today. XFCE here.
Comment by citadeldimon (citadeldimon) - Tuesday, 08 October 2013, 05:20 GMT
Same problem here after upgrading to GNOME 3.10. Openbox here.
Comment by Minjie Zha (magic003) - Wednesday, 09 October 2013, 10:39 GMT
Same problem here after upgrade today. XFCE here.

Loading...