Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#37225 - [eog] Trouble with certain JPEG files

Attached to Project: Arch Linux
Opened by Conley Moorhous (conley) - Monday, 07 October 2013, 15:49 GMT
Last edited by Jan Alexander Steffens (heftig) - Monday, 04 November 2013, 15:37 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Jan Alexander Steffens (heftig)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

These jpgs are normal as far as I can tell; I had been using them as background pictures (they still work, just not in EOG). I have attached a video showing EOG failing to open these two files while succeeding opening another jpg (png screenshot converted to jpg via GIMP). I have also attached the files in question.
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Monday, 04 November 2013, 15:37 GMT
Reason for closing:  Upstream
Comment by Gaetan Bisson (vesath) - Monday, 07 October 2013, 18:02 GMT
So... Your bug report is actually about EOG?
Comment by Gaetan Bisson (vesath) - Monday, 07 October 2013, 18:03 GMT
By the way, your files are displayed just fine by both feh and geeqie. Feel freeo to include any relevant error output from eog...
Comment by Conley Moorhous (conley) - Friday, 11 October 2013, 01:09 GMT
Yes, EOG. It does not report anything from the command line.
Comment by Zach Jibben (threeofsix) - Saturday, 12 October 2013, 18:52 GMT
I am having exactly the same problem. Images open fine in Shotwell and other programs, but EOG only shows a thin strip along the top. EOG was working fine in version 3.8.2-1, but downgrading doesn't seem to be an option unless you want to downgrade all of GNOME (it wouldn't even run when I tried it). I'll probably be using Shotwell until a fix comes along..
Comment by Jan Alexander Steffens (heftig) - Saturday, 12 October 2013, 18:54 GMT
If you can, please try obtaining EOG from git and bisecting it.
Comment by Conley Moorhous (conley) - Saturday, 12 October 2013, 22:11 GMT
I can't get it to work with any version of EOG, going all the way back to 3.8.0. It looks like something is amiss with the environment EOG 3.10 is in rather than the application itself... does it use another library to read JPG data? Or does it have a cache folder that would be messing things up?

I tried deleting pertinent folders in .config/, but it made no difference.

EDIT: To clarify, it was working when I had Gnome 3.8, but when I upgraded to the new 3.10 packages, it quit working. So it worked with 3.8's environment, but not with 3.10's.
Comment by Conley Moorhous (conley) - Tuesday, 15 October 2013, 19:09 GMT
Still not working in 3.10.1
Comment by Jan de Groot (JGC) - Wednesday, 16 October 2013, 07:38 GMT
Your images show fine here. There's a bugreport upstream about big images not opening, but those are about images with 32K width or height, yours are just 1920x1080. The 32K limit is a limitation of cairo. As cairo is involved, do you have any custom version of cairo installed, and which drivers and hardware do you run this on?
Comment by Conley Moorhous (conley) - Wednesday, 16 October 2013, 11:19 GMT
No custom version of cairo, but I am running the git version of xf86-video-intel; I didn't even think of that!

[conley@styrka ~]$ pacman -Qi xf86-video-intel-git
Name : xf86-video-intel-git
Version : 2.99.904.2.g97d809c-1

[conley@styrka ~]$ pacman -Qi intel-dri
Name : intel-dri
Version : 9.2.1-1


I have Intel Sandy Bridge (HD3000) graphics.
Comment by Conley Moorhous (conley) - Wednesday, 16 October 2013, 11:27 GMT
Reverting to xf86-video-intel fixes things. Sorry about the trouble! If, when 3.0 is released, it is still a problem, I'll report it against xf86-video-intel. Thanks for setting me straight!
Comment by Jan de Groot (JGC) - Wednesday, 16 October 2013, 11:31 GMT
If current git still has this problem it would be better to file a bug upstream at bugs.freedesktop.org against xf86-video-intel. If they don't know about your bug, they won't fix your bug either.
Comment by Conley Moorhous (conley) - Wednesday, 16 October 2013, 12:14 GMT Comment by Dan Andresan (forumache) - Thursday, 24 October 2013, 11:01 GMT
Same problem here. I actually had the problem with other files, but testing with mt_hood.jpg you provided yields same result (just a line at the top of the image).
Adding my comment because, although I have an intel card, my driver is not from git at all.

[dan@imperial ~]$ pacman -Q|grep intel
intel-dri 9.2.2-1
intel-ucode 20130906-1
libva-intel-driver 1.2.0-1
xf86-video-intel 2.21.15-1
Comment by Conley Moorhous (conley) - Thursday, 24 October 2013, 18:11 GMT
Interesting... I'll pass this on to Chris Wilson.
Comment by Conley Moorhous (conley) - Monday, 04 November 2013, 15:34 GMT
Requesting closure; the latest git commits fixed this upstream.

Loading...