Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#37224 - [Gnome 3.10] Brightness keys no longer working

Attached to Project: Arch Linux
Opened by Conley Moorhous (conley) - Monday, 07 October 2013, 15:39 GMT
Last edited by Jan Alexander Steffens (heftig) - Saturday, 16 November 2013, 12:19 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Brightness hotkeys worked in Gnome 3.8. No longer working after the upgrade today; now instead of changing the brightness, they simply show the indicator where the current brightness level is and move up and down one 'notch' from there (but don't actually change the brightness). Brightness can be changed from the new combined menu in the top-right corner just fine.

The video shows what I am talking about. The brightness works fine when adjusting via the menu. It does nothing when adjusting via hotkey, but the indicator can move back and forth one notch. Each time the indicator shows up, I am pressing the key combination (Fn + Brightness Up) multiple times, first in one direction, then in the other.
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Saturday, 16 November 2013, 12:19 GMT
Reason for closing:  Fixed
Additional comments about closing:  Patches added.
Comment by Joel Teichroeb (klusark) - Tuesday, 08 October 2013, 00:27 GMT
I'm having the same issue. The brightness up key works for me, but the brightness down key causes the brightness to change, and then it instantly changes back causing my display to flicker if I hold it down.
Comment by Eugene de Beste (Banshee1221) - Tuesday, 08 October 2013, 08:50 GMT
I can confirm the issue. Neither my up nor down works as in the screencast. Was working in Gnome 3.8.
I'm using a Clevo W150HN based rebranded laptop.
Comment by Vladimir (bolodya) - Tuesday, 08 October 2013, 20:02 GMT
Exactly the same thing here. I can't change brightness by Fn+F2..F3 buttons, but can do it from status menu and settings window. Fn+F2 and Fn+F3 buttons are identified by system and by Gmome beacause I can see a brightness indicator (as it was before) when press them.
Comment by Guillaume Hayot (PostBlue) - Wednesday, 09 October 2013, 20:10 GMT
Same thing on a Samsung N210Plus, with acpi_osi=Linux acpi_backlight=vendor in GRUB and or without samsung-tools installed. Even the indicator is weird : the brightness change only one over two steps of the cursor. We can see it as a corrolary of the Fn brightness control : it moves over one step, but it's blocked before the second one that should be effective and change the brightness of the screen.
Comment by Vladimir (bolodya) - Thursday, 10 October 2013, 10:14 GMT
by the way, the wifi-on/off Fn+F12 is also broken (Samsung NP300U1A laptop). Looks like it should be fixed in the same place.
Comment by Conley Moorhous (conley) - Sunday, 13 October 2013, 14:27 GMT
Does this need reported upstream? It may seem like a minor issue but it does affect usability.
Comment by Vladimir (bolodya) - Friday, 18 October 2013, 08:04 GMT Comment by Vladimir (bolodya) - Saturday, 19 October 2013, 19:54 GMT
Here are PKGDUIDs with patches for a current packages (for those who cant whait till next update)

!!! make gnome-settings-daemon package only after patched gnome-desktop is installed !!!

It solved topic problem on my Samsung NP300U1
Comment by Conley Moorhous (conley) - Saturday, 19 October 2013, 23:01 GMT
Thanks Vladimir, hopefully this gets committed and a bugfix is released soon.
Comment by Conley Moorhous (conley) - Saturday, 19 October 2013, 23:12 GMT
By the way, that patch causes Gnome to crash on me (where the only option is to log out).
Comment by Vladimir (bolodya) - Monday, 21 October 2013, 19:07 GMT
here is an updated mutter patch.

These patches are for packages versions:
mutter.tar.gz 3.10.1.1-1
gnome-desktop.tar.gz 1:3.10.1-1
gnome-settings-daemon.tar.gz 3.10.1-1
Comment by Conley Moorhous (conley) - Monday, 21 October 2013, 20:26 GMT
Ah, now things work properly. Thanks again!
Comment by Vladimir (bolodya) - Thursday, 14 November 2013, 11:02 GMT
gnome-settings-daemon package is updated, but patch is not included...

Here is a new patch:
Comment by Vladimir (bolodya) - Thursday, 14 November 2013, 11:24 GMT
uuups, here is a corrected file
Comment by Conley Moorhous (conley) - Friday, 15 November 2013, 15:41 GMT
Could we get these patches included in 3.10.2? These are applied upstream, they just didn't make it in time for 3.10.2.
Comment by Vladimir (bolodya) - Friday, 15 November 2013, 18:48 GMT
gnome-settings-daemon 3.10.2 in my previous post,
mutter 3.10.2 is attached
gnome-desktop is still 3.10.1, will also post it here when it will be released.

Loading...