Community Packages

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#37110 - [virtualbox] shared folders don't work with 3.11 kernel

Attached to Project: Community Packages
Opened by William Gathoye (wget) - Saturday, 28 September 2013, 17:27 GMT
Last edited by Ionut Biru (wonder) - Tuesday, 22 October 2013, 09:16 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Ionut Biru (wonder)
S├ębastien Luttringer (seblu)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No


Since the upgrade to a 3.11 kernel, any ArchLinux (or any others distribution) guests running a 3.11 kernel cannot access to the folders that have been shared. A patch has been submitted upstream [1] but won't be available until a new maintenance version is released (in the next 2 months or wait for the 4.3 which is currently in beta).

Since that bug is rather blocking for all of us running VM with updated kernels, could you then backport that fix to the current VirtualBox additions?

This task depends upon

Closed by  Ionut Biru (wonder)
Tuesday, 22 October 2013, 09:16 GMT
Reason for closing:  Not a bug
Comment by William Gathoye (wget) - Saturday, 28 September 2013, 17:32 GMT
This bug has already been reported in the wiki at

This is the reason why I'm submitting this bug report to the right location (here).

The only solution for now, without that patch, is to downgrade to a 3.10 kernel which is rather tricky/annoying.
Comment by Christopher Reimer (CReimer) - Friday, 18 October 2013, 13:01 GMT
  • Field changed: Percent Complete (100% → 0%)
Bug is not fixed.
Comment by S├ębastien Luttringer (seblu) - Sunday, 20 October 2013, 21:15 GMT
It was tested and it works for me. So please be more specific than "bug is not fixed".
Comment by William Gathoye (wget) - Tuesday, 22 October 2013, 08:58 GMT
Yes indeed, it has been fixed in a new 4.2 virtualbox modules compilation you provided.
And now, with the newly released 4.3 VirtualBox release, this bug has been completely fixed, there is no need to backport any upstream code any more.