Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#3707 - xdm does not work in modular xorg

Attached to Project: Arch Linux
Opened by Tom Killian (tomk) - Wednesday, 04 January 2006, 22:56 GMT
Last edited by Tobias Powalowski (tpowa) - Thursday, 05 January 2006, 06:59 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Jan de Groot (JGC)
Architecture not specified
Severity High
Priority Normal
Reported Version 0.7 Wombat
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


Following today's upgrade to the new xorg from [testing], I can no longer log in using xdm. Entering xdm as root on the command line produces no response.
This task depends upon

Closed by  Jan de Groot (JGC)
Saturday, 18 February 2006, 18:29 GMT
Reason for closing:  Fixed
Additional comments about closing:  The new xorg-xdm package should fix these problems. If you still have problems, file a new one.
Comment by 甘露(Lu Gan) (ganlu) - Thursday, 05 January 2006, 01:40 GMT
Check /usr/lib/X11/xdm/Xservers, change line like this:
x:5:respawn:/usr/bin/xdm -nodaemon -config /etc/X11/xdm/archlinux/xdm-config

and /etc/inittab
:0 local /usr/bin/X -dpi 96 -nolisten tcp

Does it work?

or Xaccess, Xresouces etc.
Comment by Tom Killian (tomk) - Thursday, 05 January 2006, 09:36 GMT
Thanks ganlu. /usr/lib/X11/xdm/Xservers does not exist on my system. The x:5:respawn:etc line exists in /etc/inittab, but it's commented out for the moment - right now, I'd be happy just to start it from CLI.

On my other system, with xorg 6.8.2, I have the line :0 local /usr/X11R6/bin/X in /etc/X11/xdm/Xservers. This was installed by default - I did not have to edit it. On the upgraded system, everything in /etc/X11/xdm has been pacsaved during the upgrade, and nothing new has been installed in /etc/X11. So I'll try reinstating the /etc/X11/xdm files and amending paths where required.
Comment by Tom Killian (tomk) - Thursday, 05 January 2006, 10:21 GMT
I've now reinstated all the .pacsave files in /etc/X11/xdm, except for xdm-config, which I copied over from /usr/share/X11/xdm. I've amended the path in Xserver to /usr/bin/X. Unfortunately, there is still no response from xdm.
Comment by Tom Killian (tomk) - Saturday, 07 January 2006, 14:25 GMT
I've been googling this a bit more, and found a couple of gentoo guys talking about it - it was over my head, tbh, but I think they tried rebuilding xdm with -export-dynamic in CFLAGS.

I've also tried wdm, which i understand is based on xdm, and the pacakge from [extra] failed as well. I rebuilt it with --x-includes=/usr/include/xorg --x-libraries=/usr/lib and it works. I'd still prefer xdm, though. :)

If any of this helps, good - if not, at least I feel like I'm doing something. :P
Comment by Jan de Groot (JGC) - Saturday, 07 January 2006, 16:45 GMT
xorg-clients will be split up in another 5 or 6 packages, one of them is a standalone xdm. Hope the autotooled version will operate like it should. Autotooled programs don't mean everything will be alright: I have to patch many things to get it installing in the right locations :(
Comment by Tom Killian (tomk) - Saturday, 07 January 2006, 18:15 GMT
Cheers, JGC. I really appreciate all the work being done on this, and I look forward to the new packages when they're ready.
Comment by Andrey Gusev (metal) - Friday, 27 January 2006, 22:06 GMT
I had same trouble too. I added to Xservers:
0: local /usr/bin/X :0
Also I couldn't execute firefox after login without full path to it. I added . /etc/profile in ~/.xsession. May be it isn't best way.
Comment by Roman Kyrylych (Romashka) - Saturday, 11 February 2006, 16:14 GMT
Xdm is not working for me too (Xorg 7).
When I uncomment x:5:respawn:/usr/bin/xdm -nodaemon in inittab I get this error:
INIT: Id "x" respawning too fast: disabled for 5 minutes
So I must start XFCE without xdm:
x:5:once:/bin/su user -l -c "/bin/bash --login -c startxfce4"