Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#37076 - [vlc] Fragmented and Stuttering MP4 video (x264)

Attached to Project: Arch Linux
Opened by Mark E. Lee (bluerider) - Thursday, 26 September 2013, 16:38 GMT
Last edited by Bartłomiej Piotrowski (Barthalion) - Monday, 11 November 2013, 11:10 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Giovanni Scafora (giovanni)
Bartłomiej Piotrowski (Barthalion)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
vlc-2.1.0-{1,2} exhibits stuttering and fragmented playback for mp4 (x264) files. Downgrading to vlc-2.08.1-a fixes the issue.

Additional info:
vlc 2.1.0-{1,2}
Tested with both vaapi and no vappi acceleration


Steps to reproduce:
Try to play an x264 encoded video (.mp4 for me) with vlc-2.1.0.
This task depends upon

Closed by  Bartłomiej Piotrowski (Barthalion)
Monday, 11 November 2013, 11:10 GMT
Reason for closing:  Fixed
Comment by Mark E. Lee (bluerider) - Thursday, 26 September 2013, 16:41 GMT
After a reinstall of vlc, I found the issue now only affects if I'm using vaapi acceleration.
Comment by Anton Hvornum (Torxed) - Friday, 27 September 2013, 20:17 GMT
I was a little bit hot on the gun posting a forum post asking about this issue, a error-output/trace can be found in the post however (thought it might be good to mention): https://bbs.archlinux.org/viewtopic.php?pid=1330345
Comment by ValdikSS (ValdikSS) - Friday, 27 September 2013, 21:39 GMT
It could be because of missing ffmpeg. VLC internal splitters are quite a shit. See https://bugs.archlinux.org/task/37095
Comment by Anton Hvornum (Torxed) - Saturday, 28 September 2013, 14:51 GMT
I wouldn't say you could rule out ffmpeg, but i've got both ffmpeg 1:2.0.1-1 and ffmpeg-compat 1:0.10.8-4 installed (and i still have the same issue)
Comment by Bartłomiej Piotrowski (Barthalion) - Sunday, 29 September 2013, 07:32 GMT
Please test VLC 2.1.0 built against ffmpeg-compat. Ready packages can be found here[1].

[1] http://pkgbuild.com/~barthalion/tmp/fs37076/
Comment by Mark E. Lee (bluerider) - Sunday, 29 September 2013, 20:55 GMT
@barthalion : Your new package works for me! Thanks!
Comment by Bartłomiej Piotrowski (Barthalion) - Monday, 30 September 2013, 07:33 GMT
That's great. I'll upload it to repository today. However before I report the problem upstream (whether VLC or ffmpeg), I would like you to upload somewhere a video sample in which the problem occurs.
Comment by Anton Hvornum (Torxed) - Monday, 30 September 2013, 08:33 GMT
For whatever reason i get "vlc: error while loading shared libraries: /usr/lib/libvlc.so.5: file too short", knowing a little but obviously not enough to get your package in place i can't be of much help :/
Comment by Mark E. Lee (bluerider) - Monday, 30 September 2013, 20:11 GMT
@bathalion : Interestingly my test clip (encoded with x.264) doesn't exhibit the tearing and fragmentation on the current version of VLC (not built against ffmpeg-compat). The original clip is over an hour long (it is the Disney movie : Alice in Wonderland) and may have been encoded with a proprietary h.264 encoder. Your version of vlc built against the ffmpeg-compat library is capable of playing back the original clip without fragmentation or tearing.
Comment by Mark E. Lee (bluerider) - Monday, 30 September 2013, 20:57 GMT
@bathalion : Find the two clips located at the following links :
<https://docs.google.com/file/d/0Bx2cO4TT8XjeMEdDbV9CS1ZPTXc/edit?usp=sharing>
<https://docs.google.com/file/d/0Bx2cO4TT8XjeQ0hlSUtMR2hodk0/edit?usp=sharing>
Comment by Bartłomiej Piotrowski (Barthalion) - Wednesday, 09 October 2013, 19:10 GMT
So I'm going to push again VLC built against ffmpeg. Please test packages from here[1] and let me know if it still doesn't work.

[1] http://pkgbuild.com/~barthalion/tmp/vlc-bugs/

Loading...