Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#37027 - [linux] 3.11.1 i686 memory corruption after suspend-to-RAM

Attached to Project: Arch Linux
Opened by Natrio (natrio) - Sunday, 22 September 2013, 17:52 GMT
Last edited by Tobias Powalowski (tpowa) - Friday, 11 October 2013, 07:25 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas Bächler (brain0)
Architecture i686
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 9
Private No

Details

Systemd-207 receives SEGV after waking up from suspemd-to-RAM on many different machines with 3.11.1 i686 kernel (core dump included):
https://bugs.archlinux.org/task/36991

Maintainer of systemd (Dave Reisner/falconindy) says that the cause of memory corruption by Linux-3.11 kernel:
https://bugs.archlinux.org/task/36991#comment114444

Rolling back to kernel 3.10 solves the problem.
There is no bug on x86_64 linux-3.11 build.

Steps to reproduce:
1) Boot with linux-3.11.1-i686 kernel.
2) systemctl suspend
3) wake up
4) if you see in logs some like "systemd[1]: Caught <SEGV>, core dump", "systemd[1]: Freezing execution", or "memory corruption", or/and systemctl don't work anymore, you got this bug.
5) if NOT, go to step 2 (several times).


Similar reports:
https://bbs.archlinux.org/viewtopic.php?pid=1326769
https://bbs.archlinux.de/viewtopic.php?pid=311974

My report to kernel bugzilla:
https://bugzilla.kernel.org/show_bug.cgi?id=61781
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Friday, 11 October 2013, 07:25 GMT
Reason for closing:  Upstream

Loading...