Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#36990 - possible race condition when booting after upgrade to systemd 207

Attached to Project: Arch Linux
Opened by Radek Podgorny (rpodgorny) - Thursday, 19 September 2013, 16:56 GMT
Last edited by Tom Gundersen (tomegun) - Friday, 20 September 2013, 13:16 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Dave Reisner (falconindy)
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

after upgrading to systemd 207, the system with multiple-device btrfs root filesystem fails to boot. revert to systemd 204 solves the issue.

someone else has also hit this bug, pasting the full description of his (and my) problem (fromaur-general@archlinux.org/msg23981.html"> http://www.mail-archive.com/aur-general@archlinux.org/msg23981.html):

I upgraded to systemd 207 today, and upon reboot received several
messages that say, "failed to open /dev/btrfs-control skipping device
registration: No such file or directory." The btrfs problem faq
suggests that running "mknod /dev/btrfs-control c 10 234" should fix
me up. However, when I run this it says that it already exists. The
only significant changes that I made were to upgrade systemd, and add
the systemd hook to mkinicpio.conf. I tried booting from external
media, and removing the systemd hook, but after re-running mkinitcpio
I still get the same result. Does anyone have any suggestions for
getting past this?

I will happily provide more information if you can tell me what would
be helpful.

Thanks,
=-Jameson
This task depends upon

Closed by  Tom Gundersen (tomegun)
Friday, 20 September 2013, 13:16 GMT
Reason for closing:  Fixed
Additional comments about closing:  in testing
Comment by Dave Reisner (falconindy) - Thursday, 19 September 2013, 18:53 GMT
It's not a race condition, and it should be fixed in testing.

Loading...