Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#36916 - [postgresql-libs] should install "pg_config_ext.h"

Attached to Project: Arch Linux
Opened by Bastian Beranek (totsilence) - Friday, 13 September 2013, 08:51 GMT
Last edited by Bartłomiej Piotrowski (Barthalion) - Saturday, 14 September 2013, 10:32 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Dan McGee (toofishes)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

Package postgresql-libs should install "pg_config_ext.h" since that file is included from "postgres_ext.h". Otherwise I'm unable to build my application which should depend only on postgresql-libs.

Here's a patch to the PKGBUILD which allows me to build my app.

--- PKGBUILD (revision 194267)
+++ PKGBUILD (working copy)
@@ -81,6 +81,7 @@
# these headers are needed by the public headers of the interfaces
install -m644 pg_config.h "${pkgdir}/usr/include/"
install -m644 pg_config_os.h "${pkgdir}/usr/include/"
+ install -m644 pg_config_ext.h "${pkgdir}/usr/include/"
install -m644 postgres_ext.h "${pkgdir}/usr/include/"
install -m644 libpq/libpq-fs.h "${pkgdir}/usr/include/libpq/"
install -m644 pg_config_manual.h "${pkgdir}/usr/include/"


Additional info:
* postgresql-libs 9.3.0-2

This task depends upon

Closed by  BartÅ‚omiej Piotrowski (Barthalion)
Saturday, 14 September 2013, 10:32 GMT
Reason for closing:  Fixed
Additional comments about closing:  postgresql 9.3.0-3

Loading...