Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#36827 - [deluge] Define WMStartupClass in .desktop file

Attached to Project: Arch Linux
Opened by Chris Jordan (MrBushido) - Sunday, 08 September 2013, 14:29 GMT
Last edited by Jan Alexander Steffens (heftig) - Tuesday, 11 February 2014, 21:14 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Jan Alexander Steffens (heftig)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: Application managers like cairo-dock think the spawned process is separate to the program that launches it, instead of grouping together under the .desktop files launcher they create additional icons for each spawned application. This behaviour can be changed by defining "WMStartupClass=deluge" in the deluge.desktop file.

Not sure if this is intentional due to this option causing undesired behaviour in other circumstances, if not, then I and many other dock users would appreciate this simple amendment!

From my

Required packages:
deluge
cairo-dock

Steps to reproduce:
1) Add deluge launcher to cairo-dock either by right clicking an open copy of deluge and chosing "make launcher", or by dragging the /usr/share/applications/deluge.desktop file on to cairo-dock.
2) Click launcher.
3) Have two entries on the dock bar :'<
4) open a console type: xprop | grep CLASS
5) click deluge window
6) console output = WM_CLASS(STRING) = "deluge", "Deluge"
7) Add "WMStartupClass=deluge" to deluge.desktop
8) Only one icon for deluge on cairo-dock \o/ <3 \o/

PS. Thank you for your efforts to make this a stellar linux distro!
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Tuesday, 11 February 2014, 21:14 GMT
Reason for closing:  Fixed
Additional comments about closing:  deluge-1.3.6-4
Comment by Alexander F. Rødseth (xyproto) - Friday, 13 September 2013, 11:47 GMT
Original subject: "Define WMStartupClass in .desktop file so app managers associate launcher with spawned process".
Comment by Gerardo Exequiel Pozzi (djgera) - Tuesday, 11 February 2014, 20:35 GMT
  • Field changed: Status (Assigned → Waiting on Response)
status? package version? upstream report?

Loading...