Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#36753 - [xulrunner][firefox] should update in sync

Attached to Project: Arch Linux
Opened by Lauri Jäntti (lartza) - Saturday, 31 August 2013, 14:40 GMT
Last edited by Bartłomiej Piotrowski (Barthalion) - Saturday, 26 July 2014, 10:53 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Ionut Biru (wonder)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No



Usually when firefox is updated it takes a long time before xulrunner PKGBUILD is updated to the same version.

For example there's currently xulrunner 22.0-1 in the repos and firefox is already 23.0.1-1

This breaks all the extensions in aur, see

Additional info:
* package version(s)

Steps to reproduce:

- Compile and install for example firefox-gnome-keyring
-> Doesn't work at all

- Compile and install xulrunner-23.0.1
- Compile and install for example firefox-gnome-keyring
-> Works just fine
This task depends upon

Closed by  Bartłomiej Piotrowski (Barthalion)
Saturday, 26 July 2014, 10:53 GMT
Reason for closing:  Fixed
Comment by Jan de Groot (JGC) - Saturday, 31 August 2013, 18:00 GMT
Why would you compile a firefox specific extension against xulrunner?
Comment by Matthew Gyurgyik (pyther) - Monday, 02 September 2013, 12:44 GMT
The official extension in named mozilla-gnome-keyring. As I understand it the plugin will also work with thunderbird and seamonkey. The plugin has C++ code which depends on a number of header files provided by xulrunner. See lines 44-54:

My knowledge on building software is fairly limited. I would be surprised if the header files differed between firefox and xulrunner. Perhaps, we should be compiling this plugin against the firefox source?

Is there a technical reason why xulrunner is not being updated at the same time as firefox?
Comment by Sebastian Schwarz (seschwar) - Wednesday, 13 November 2013, 18:01 GMT
  • Field changed: Percent Complete (100% → 0%)
firefox does not provide any header files, but xulrunner does. Please reopen to enable a longer discussion.
Comment by Matt (madalu) - Monday, 16 December 2013, 04:42 GMT
I too am curious about whether there is a technical reason for not updating xulrunner, which has been flagged out of date since September and is still at version 23 (whereas the most recent release is 26).