Community Packages

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#36713 - [binutils-multilib] Request to enable x86_64-pep target

Attached to Project: Community Packages
Opened by Dan Ziemba (zman0900) - Wednesday, 28 August 2013, 21:49 GMT
Last edited by Eric Belanger (Snowman) - Friday, 14 February 2014, 20:12 GMT
Task Type Feature Request
Category Packages: Multilib
Status Closed
Assigned To Florian Pritz (bluewind)
Jan Steffens (heftig)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No


I would like to request that binutils-multilib be built with '--enable-targets=x86_64-pep'. This enables the i386pep emulation for ld which is necessary when building Xen for xen.efi to compile properly. xen.efi is the boot binary for UEFI systems.

Additional info:
* package version(s)
binutils-multilib 2.23.2-3
xen >=4.2 (maybe older also)
* config and/or log files etc.

Steps to reproduce:
Attempt to build Xen (several packages available in AUR). xen.efi will not be produced and instead you will find the file xen\arch\x86\efi\disable stating that ld does not support -m i386pep. If binutils is rebuilt with '--enable-targets=x86_64-pep' added to its configuration, xen.efi is built and works properly.
This task depends upon

Closed by  Eric Belanger (Snowman)
Friday, 14 February 2014, 20:12 GMT
Reason for closing:  Won't implement
Additional comments about closing:  binutils-multilib has been remove from the repos
Comment by Dan Ziemba (zman0900) - Saturday, 14 December 2013, 04:14 GMT
2.24 of binutils is out. Just bumping this to see if there's a chance of getting '--enable-targets=x86_64-pep' added to the config.