Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#36604 - [kdebase-workspace] plasma-desktop segfaults

Attached to Project: Arch Linux
Opened by patrick (potomac) - Tuesday, 20 August 2013, 01:40 GMT
Last edited by Andrea Scarpino (BaSh) - Saturday, 07 September 2013, 16:30 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andrea Scarpino (BaSh)
Sven-Hendrik Haase (Svenstaro)
Architecture i686
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 18
Private No

Details

Description:

after a "pacman -Syu" KDE was upgraded to KDE 4.11 and glibc to the last version ( 2.18-2 )

but when I did a reboot KDE4.11 can't start ( I can login in KDM but after that KDE is unable to start ), plasma fails to start ( segfault ), it's a critical bug because I can not use KDE4.11, here is the backtrace :

Application: Outil de gestion de fenĂȘtres Plasma (plasma-desktop), signal: Segmentation fault
Using host libthread_db library "/usr/lib/libthread_db.so.1".
[Current thread is 1 (Thread 0xb549c740 (LWP 464))]

Thread 3 (Thread 0xae29bb40 (LWP 476)):
#0 0xb777b424 in __kernel_vsyscall ()
#1 0xb6c3ac5b in pthread_cond_wait@@GLIBC_2.3.2 () from /usr/lib/libpthread.so.0
#2 0xb0df0ed2 in ?? () from /usr/lib/libQtScript.so.4
#3 0xb0df0f1f in ?? () from /usr/lib/libQtScript.so.4
#4 0xb6c36ee0 in start_thread () from /usr/lib/libpthread.so.0
#5 0xb5fd801e in clone () from /usr/lib/libc.so.6

Thread 2 (Thread 0xa6141b40 (LWP 505)):
#0 0xb599be14 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#1 0xb599c39a in ?? () from /usr/lib/libglib-2.0.so.0
#2 0xb599c548 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#3 0xb6df19af in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#4 0xb6dc0ec3 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#5 0xb6dc11e9 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6 0xb6cafb1d in QThread::exec() () from /usr/lib/libQtCore.so.4
#7 0xb6da1354 in ?? () from /usr/lib/libQtCore.so.4
#8 0xb6cb240f in ?? () from /usr/lib/libQtCore.so.4
#9 0xb6c36ee0 in start_thread () from /usr/lib/libpthread.so.0
#10 0xb5fd801e in clone () from /usr/lib/libc.so.6

Thread 1 (Thread 0xb549c740 (LWP 464)):
[KCrash Handler]
#6 0xb6cfcfc6 in QString::fromLatin1_helper(char const*, int) () from /usr/lib/libQtCore.so.4
#7 0xa6f3c395 in Akonadi::ServerManager::instanceIdentifier() () from /usr/lib/libakonadi-kde.so.4
#8 0xa6f3c3f6 in ?? () from /usr/lib/libakonadi-kde.so.4
#9 0xa6f3c6aa in Akonadi::ServerManager::serviceName(Akonadi::ServerManager::ServiceType) () from /usr/lib/libakonadi-kde.so.4
#10 0xa6f3d102 in Akonadi::ServerManager::state() () from /usr/lib/libakonadi-kde.so.4
#11 0xa6f3dc5f in ?? () from /usr/lib/libakonadi-kde.so.4
#12 0xb6dd386a in QMetaCallEvent::placeMetaCall(QObject*) () from /usr/lib/libQtCore.so.4
#13 0xb6ddb6bb in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#14 0xb62bd9a4 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#15 0xb62c43b3 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#16 0xb75076a4 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#17 0xb6dc245a in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#18 0xb6dc579d in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/libQtCore.so.4
#19 0xb6dc5cac in QCoreApplication::sendPostedEvents(QObject*, int) () from /usr/lib/libQtCore.so.4
#20 0xb6df219e in ?? () from /usr/lib/libQtCore.so.4
#21 0xb599c0de in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#22 0xb599c488 in ?? () from /usr/lib/libglib-2.0.so.0
#23 0xb599c548 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#24 0xb6df198f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#25 0xb636d41e in ?? () from /usr/lib/libQtGui.so.4
#26 0xb6dc0ec3 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#27 0xb6dc11e9 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#28 0xb6dc698e in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#29 0xb62bbe44 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#30 0xaf999937 in kdemain () from /usr/lib/libkdeinit4_plasma-desktop.so
#31 0x0804f3ab in _start ()


I have the same problem with a PC and a laptop, so it's probably a problem between kde4.11 and glibc, I don't understand why this bug was not detected during the testing period


Additional info:
* package version(s) kde4.11 packages ( 4.11.0-1 ) and glibc 2.18-2
* config and/or log files etc.


Steps to reproduce:
just do a "pacman -Syu", if you use KDE4.11 you will get a segfault with plasma-desktop, maybe it's a problem with glibc, or maybe KDE4 packages must be rebuild with the last version of glibc
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Saturday, 07 September 2013, 16:30 GMT
Reason for closing:  Fixed
Additional comments about closing:  kdebase-workspace 4.11.0-3
Comment by patrick (potomac) - Tuesday, 20 August 2013, 02:29 GMT
some precision: my system is up-to-date ( pacman -Syu ),

and I use the i686 version of archlinux,

maybe the problem only occurs in the i686 version of archlinux
Comment by patrick (potomac) - Tuesday, 20 August 2013, 03:06 GMT
I found a workaround :

edit the file /usr/share/autostart/plasma-desktop.desktop

and replace the line:

Exec=plasma-desktop

by this :

Exec=sleep 10 && plasma-desktop

the segfault is gone and KDE 4.11 now can start without problem,

this workaround was found in a gentoo forum :

http://forums.gentoo.org/viewtopic-t-967222.html


Comment by patrick (potomac) - Tuesday, 20 August 2013, 03:16 GMT
another link for the workaround :

http://forums.gentoo.org/viewtopic-t-967554.html

it confirm that the problem only occurs on 32 bits version of archlinux
Comment by Seb (SebRmv) - Tuesday, 20 August 2013, 07:42 GMT
I have the same kind of problem on a x86_64 version of arch.
Can this be related to nvidia driver?
Comment by Flat Eric (flateric) - Tuesday, 20 August 2013, 07:58 GMT
I have i686 version and radeon driver (for ATI x1400). So I think, that this problem don't relate with GPU driver.
Comment by Hrvoje S (sumski) - Tuesday, 20 August 2013, 17:21 GMT
It's not glibc incompatibility, we at openSUSE have reporters from oS 12.2...
Upstream report: https://bugs.kde.org/show_bug.cgi?id=322283
Downstream (openSUSE) report: https://bugzilla.novell.com/show_bug.cgi?id=829298
Comment by Seb (SebRmv) - Wednesday, 21 August 2013, 05:47 GMT
Please find attached a photo of my screen when I log on Plasma desktop from KDM.
Before that, I get two crash. One of them is related to kmix.
Unfortunately, I am not able to attach the backtraces (or else tell me how I can do): when I try to save the backtrace in a file with the "crash manager", I get another crash.

uname -a returns:

Linux Luke 3.10.7-1-ARCH #1 SMP PREEMPT Thu Aug 15 11:55:34 CEST 2013 x86_64 GNU/Linux
Comment by Seb (SebRmv) - Wednesday, 21 August 2013, 05:55 GMT
Hi again,
I was mistaken. The problem on my computer was that my / partition was full.
Sorry to have polluted this thread.
Comment by Andrea Scarpino (BaSh) - Wednesday, 21 August 2013, 12:03 GMT
@potomac
is this fixed by kdebase-workspace 4.11.0-2?
Comment by patrick (potomac) - Wednesday, 21 August 2013, 12:35 GMT
@andrea Scarpino : no it doesn't help, kdebase-workspace 4.11.0-2 doesn't fix the problem,

the only solution ( for now ) is this workaround :

edit the file /usr/share/autostart/plasma-desktop.desktop

and replace the line:

Exec=plasma-desktop

by this :

Exec=sleep 10 && plasma-desktop

"Exec=sleep 3 && plasma-desktop" can also work but it is safe to add more delay like "sleep 10"
Comment by Andrea Scarpino (BaSh) - Wednesday, 28 August 2013, 07:35 GMT
@potomac
This[1] patch should fix the issue but looks too big to me. KDE 4.11.1 will be released next week; you could try to apply this patch or wait.

[1] http://commits.kde.org/kde-workspace/af6653c766981ca81bac499de284abcdc2c7f08f
Comment by Hrvoje S (sumski) - Wednesday, 28 August 2013, 18:35 GMT

Loading...