Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#36589 - [curl] 7.32.0-1 update breaks VMware Workstation 9.0.2

Attached to Project: Arch Linux
Opened by qozy (qozy) - Sunday, 18 August 2013, 20:02 GMT
Last edited by Dave Reisner (falconindy) - Friday, 15 November 2013, 16:54 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Dave Reisner (falconindy)
Architecture All
Severity Medium
Priority Low
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

The latest update of curl (7.32.0-1) breaks the latest VMware Workstation (9.0.2).


Steps to reproduce:
1. Update curl (pacman -Sy curl)
2. start VMware Workstation (/usr/bin/vmware)
3. The window opens and closes quickly. The following error message appears in the terminal:
Aborted (core dumped)

Downgrading to curl to version 7.31.0-1 solves the issue.
This task depends upon

Closed by  Dave Reisner (falconindy)
Friday, 15 November 2013, 16:54 GMT
Reason for closing:  Fixed
Additional comments about closing:  Reported fixed with curl 7.33.0 or vmware 10.
Comment by Dave Reisner (falconindy) - Monday, 19 August 2013, 01:50 GMT
There's nothing I can do with this bug report without a backtrace or any real debugging info. Particularly given that vmware is a binary blob from the AUR, there's even less that I'm willing to do.
Comment by Austen Frazier (acfrazier) - Thursday, 22 August 2013, 00:52 GMT
ran it under gdb, here's your backtrace. As earlier stated, downgrading resolves the issue.
Comment by Dave Reisner (falconindy) - Thursday, 22 August 2013, 02:22 GMT
Semi-useful, but it'd be nice to know what the parameters passed to curl_multi_add_handle were. Seems like curl 7.32.0 now crashes on some bad value that vmware was passing rather than returning gracefully.
Comment by Dave Reisner (falconindy) - Wednesday, 25 September 2013, 16:33 GMT
ping? Any useful info you can add here?
Comment by Austen Frazier (acfrazier) - Thursday, 26 September 2013, 02:54 GMT
As you said, since VMware is a binary blob I have about the same clue as what paramaters are passed to curl_multi_add_handle as you do.
Comment by Dave Reisner (falconindy) - Thursday, 26 September 2013, 03:00 GMT
But you can run 'bt full' with debug symbols and see what the values are on the stack/heap in libcurl...
Comment by Dave Reisner (falconindy) - Friday, 15 November 2013, 13:31 GMT
Ping. Still a problem with v7.33.0?
Comment by Austen Frazier (acfrazier) - Friday, 15 November 2013, 16:42 GMT
I've been using VMware 10.0.1 now and it was evidently fixed in their code because it worked with 7.32.0. I will install VMWare 9 and test though because not everyone has a site license to upgrade with.
Comment by Austen Frazier (acfrazier) - Friday, 15 November 2013, 16:51 GMT
Reinstalled vmware 9.0.2. Problem is resolved with newest libcurl.

Loading...