Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#36539 - [linux] 3.10.6-2 kernel panic Radeon 6320

Attached to Project: Arch Linux
Opened by Mikhail Yatsenko (xstream) - Thursday, 15 August 2013, 07:03 GMT
Last edited by Gerardo Exequiel Pozzi (djgera) - Sunday, 29 September 2013, 21:26 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Thomas Bächler (brain0)
Architecture x86_64
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Description:

After update to 3.10.6-2 on login to Gnome system goes into kernel panic:

"Kernel panic - not syncing: Fatal exception in interrupt
drm_kms_helper: panic occurred, switching back to text console"

Additional info:
* linux-3.10.6-2
* device: Asus EEE PC 1215B (Radeon 6320)

Steps to reproduce:
1. Boot Asus 1215B in linux 3.10.6-2
2. Login in GNOME 3
3. Kernel panic
This task depends upon

Closed by  Gerardo Exequiel Pozzi (djgera)
Sunday, 29 September 2013, 21:26 GMT
Reason for closing:  Fixed
Additional comments about closing:  in 3.11
Comment by Aanjaneya Mishra (amsri) - Thursday, 15 August 2013, 22:08 GMT
I have the the same problem whether I login to desktop enviornment or go to tty2. It is just panic all the time upon boot.

lspci | grep VGA
01:05.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RS880M [Mobility Radeon HD 4225/4250]
02:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Park [Mobility Radeon HD 5430/5450/5470] (rev ff)

I have the discrete card disabled using acpi_call.
Comment by Andres Kanski (akanski) - Friday, 16 August 2013, 01:28 GMT
The reported kernel panic is caused by broadcom wireless [brcmsmac]
https://bbs.archlinux.org/viewtopic.php?id=168177
Comment by Natrio (natrio) - Friday, 16 August 2013, 06:32 GMT
I have same kernel panic on Intel Sandy Bridge after last glibc+bilutils update. Without any broadcom wireless.
Kernel goes panic in a boot time on KMS activate step.
linux-3.10.6-2
glibc-2.18-1
binutils-2.23.2-3

I got system back after downgrading to glibc-2.17-6, binutils-2.23.2-2 and rebiulding initcpio.

P.S.
linux-3.10.7-1 don't help this, it have same panic, see the shot in attachment.
Comment by Aanjaneya Mishra (amsri) - Friday, 16 August 2013, 08:53 GMT
I got the system to a working state just by downgrading the kernel to 3.10.5.1 using pacman -U. I have a broadcom wireless too.
Comment by Andres Kanski (akanski) - Friday, 16 August 2013, 17:01 GMT
As far as I know by reading Arch forum, there were some issues related to glibc-2.18-1 on 32-bit system of somebody else, which have already been solved in glibc-2.18-2 (x86_64, i686). In fact, that other kernel panic looks like another one.

https://projects.archlinux.org/svntogit/packages.git/log/trunk?h=packages/glibc
Comment by Natrio (natrio) - Saturday, 17 August 2013, 16:11 GMT
The hack in glibc-2.18-2 is working for me.
Comment by Pavol (palica) - Monday, 19 August 2013, 15:25 GMT
Hi, I have the same problems with a intel graphics card and a broadcom wifi adapter on my laptop and linux 3.10.6-2

Notebook
product: PORTEGE R700 (0000000000)
vendor: TOSHIBA
version: PT310E-06N02GCZ
width: 64 bits
*-firmware
description: BIOS
vendor: TOSHIBA
version: Version 2.20
date: 12/22/2011
*-cpu
product: Intel(R) Core(TM) i5 CPU M 460 @ 2.53GHz


# lspci
00:00.0 Host bridge: Intel Corporation Core Processor DRAM Controller (rev 02)
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)
00:16.0 Communication controller: Intel Corporation 5 Series/3400 Series Chipset HECI Controller (rev 06)
00:19.0 Ethernet controller: Intel Corporation 82577LC Gigabit Network Connection (rev 06)
00:1a.0 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 06)
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 06)
00:1c.0 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 1 (rev 06)
00:1c.1 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 2 (rev 06)
00:1c.2 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 3 (rev 06)
00:1c.3 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 4 (rev 06)
00:1d.0 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 06)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev a6)
00:1f.0 ISA bridge: Intel Corporation Mobile 5 Series Chipset LPC Interface Controller (rev 06)
00:1f.2 SATA controller: Intel Corporation 5 Series/3400 Series Chipset 4 port SATA AHCI Controller (rev 06)
00:1f.6 Signal processing controller: Intel Corporation 5 Series/3400 Series Chipset Thermal Subsystem (rev 06)
01:00.0 SD Host controller: Ricoh Co Ltd MMC/SD Host Controller (rev 01)
02:00.0 Network controller: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller (rev 01)
ff:00.0 Host bridge: Intel Corporation Core Processor QuickPath Architecture Generic Non-core Registers (rev 02)
ff:00.1 Host bridge: Intel Corporation Core Processor QuickPath Architecture System Address Decoder (rev 02)
ff:02.0 Host bridge: Intel Corporation Core Processor QPI Link 0 (rev 02)
ff:02.1 Host bridge: Intel Corporation Core Processor QPI Physical 0 (rev 02)
ff:02.2 Host bridge: Intel Corporation Core Processor Reserved (rev 02)
ff:02.3 Host bridge: Intel Corporation Core Processor Reserved (rev 02)

I have the latest glibc installed (pacman -Q glibc glibc 2.18-2) and this does not solve the issue for me (this is a 64bit system).

I am going to try the new kernel 3.10.7-1.

Comment by Andres Kanski (akanski) - Monday, 19 August 2013, 18:13 GMT
The following commit is causing the malfunction in broadcom wireless:
https://git.kernel.org/cgit/linux/kernel/git/stable/linux-stable.git/commit/?id=ef47a5e4f1aaf1d0e2e6875e34b2c9595897bef6

Indeed, I've had no trouble with brcmsmac module after reversing those changes in mac80211/minstrel_ht:
https://bbs.archlinux.org/viewtopic.php?id=168177&p=2
Comment by Vincent Storme (vincentstorme) - Tuesday, 20 August 2013, 18:39 GMT
Adding my experience:

MacBook Pro w/ BCM43224 & 3.10.7-1

brcmsmac kernel panics after connecting to a network

Installed broadcom-wl from the AUR and everything works again
Comment by Christian Hesse (eworm) - Thursday, 22 August 2013, 15:51 GMT
The reported problem is completely unrelated to the Radeon graphics. The panic occurs when a division by zero happens in brcms_c_calc_frame_time(). The best solution to date is to disable CCK rates for Broadcom hardware as Felix Fietkau proposes:
http://www.gossamer-threads.com/lists/linux/kernel/1768699#1768699

This works reliable and makes the system stable again. I have changed the patch to apply to a 3.10.y stable kernel:
http://www.eworm.de/download/linux/mac80211_cck_rates.patch

Please apply to Arch default kernel.
Comment by Andres Kanski (akanski) - Friday, 23 August 2013, 16:46 GMT
Felix Fietkau's patch limits cck rate sampling in mac80211/minstrel_ht to drivers that can handle it in order to avoid the use of this feature on hardware that doesn't work with it, so this stuff could be used as a temporary measure until that malfunction in brcmsmac is fixed, according to Arend van Spriel's objection.

https://lkml.org/lkml/2013/8/20/125

On the other hand, I cannot figure out why Arch maintainers do not provide any feedback on their task. Effectively, there's been no response to the previous post for now, despite the fact that the above-mentioned patch comes from a very reliable mailing list.

https://lkml.org/lkml/2013/8/20/19
Comment by Andrey Kojevnikov (korjjj) - Sunday, 25 August 2013, 14:58 GMT
MacBook Air Mid 2011 here. BCM43224. 3.10.[7-9]
Kernel panic at random during network activity.
Applied the patch provided by Christian. Works fine.

Can we rename this from Radeon to Broadcom issue?
Comment by Natrio (natrio) - Sunday, 25 August 2013, 15:03 GMT
This is NOT a Radeon and NOT a Broadcom issue!
https://bugs.archlinux.org/task/36539#comment113261
Comment by Christian Hesse (eworm) - Sunday, 25 August 2013, 15:08 GMT
This is related to Broadcom, the thread you linked is something different. Look at the first image, it shows something about brcms_c_calc_frame_time() which your one does not.
Comment by Andrey Kojevnikov (korjjj) - Sunday, 25 August 2013, 15:56 GMT
@Natrio are You sure your trace is related to this task?
Comment by Draskóczi Jenő (jensd) - Thursday, 29 August 2013, 20:44 GMT
Hello everybody! Sorry for my english.
I have Asus eeepc too (1225b). The problem is same as problem of Mikhail. I have an n wireless router. I disabled „n” mode (I changed the wireless mode 11g only). The kernel panic is dicontinued. I hope this help somebody to solve the problem.
Comment by Dave Aitken (actionshrimp) - Monday, 02 September 2013, 12:06 GMT
Just another confirmation that the patch works great (also on a MacBook Air Mid 2011).
Comment by Dave Aitken (actionshrimp) - Wednesday, 04 September 2013, 20:40 GMT
Looks like this is fixed in 3.11-1 (currently in the testing repo)
Comment by Christian Hesse (eworm) - Tuesday, 17 September 2013, 07:17 GMT
linux 3.11.1-1 is in [core], so we can close this.

Loading...