Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#36533 - [lxdm] don't start session correctly along systemd standard

Attached to Project: Community Packages
Opened by lesebas (lesebas) - Wednesday, 14 August 2013, 21:13 GMT
Last edited by György Balló (City-busz) - Friday, 20 September 2013, 09:41 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To György Balló (City-busz)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

When I launch multi-user session (xfce) with lxdm the command 'loginctl' return only the first user logged but not the others ones. Example with user1 and user2 connected :

[code][user2@Vulpus ~]$ loginctl
SESSION UID USER SEAT
1 1000 user1 seat0

1 sessions listed.
[user2@Vulpus ~]$[/code]

lxdm 0.4.1-23
xfce4-session 4.10.1-2


Steps to reproduce:
Install xfce4
Install lxdm
Run 2 users session from lxdm
see the result of the command 'loginctl'

This bug me be related to the the task 36446 :

[url]https://bugs.archlinux.org/task/36446[/url]
This task depends upon

Closed by  György Balló (City-busz)
Friday, 20 September 2013, 09:41 GMT
Reason for closing:  Fixed
Additional comments about closing:  lxdm 0.4.1-27
Comment by György Balló (City-busz) - Friday, 06 September 2013, 06:18 GMT
You are right. Unfortunately, lxdm doesn't handle the sessions correctly, and it's not easy to fix that. I suggest you to report this problem to upstream:
https://sourceforge.net/tracker/?limit=25&group_id=180858&atid=894869&status=1&category=1272912
Comment by lesebas (lesebas) - Friday, 06 September 2013, 11:32 GMT Comment by György Balló (City-busz) - Wednesday, 11 September 2013, 23:58 GMT
Thanks for the upstream report, dgod implemented out of process PAM support in LXDM, which fixes the problem. I applied these changes in lxdm 0.4.1-26.
Comment by lesebas (lesebas) - Friday, 20 September 2013, 09:37 GMT
  • Field changed: Percent Complete (100% → 0%)
Hello, OK it seams working better now for the loginctl command. But the problem is if you have 2 users connected when you you come back to the greeter screen (lxdm -c USER_SWITCH) if you try to connect to the first user it always come-back to the last session opened.

Loading...