Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#36519 - [linux] Kernel doesn't boot using EFISTUB

Attached to Project: Arch Linux
Opened by ValdikSS (ValdikSS) - Tuesday, 13 August 2013, 15:48 GMT
Last edited by Tobias Powalowski (tpowa) - Wednesday, 14 August 2013, 06:29 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas B├Ąchler (brain0)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
linux 3.10.6-2 doesn't boot using EFISTUB. Nothing happens, just black screen. If you try to boot it using UEFI Shell, then shell just hangs without clearing the screen. 3.10.5-1 works fine. 3.10.6-2 with GRUB2-EFI also works fine.
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Wednesday, 14 August 2013, 06:29 GMT
Reason for closing:  Duplicate
Additional comments about closing:  #33745
Comment by Tobias Powalowski (tpowa) - Tuesday, 13 August 2013, 16:16 GMT
Which bootloader do you use?
Comment by ValdikSS (ValdikSS) - Tuesday, 13 August 2013, 16:37 GMT
Tobias, no bootloader, just booting with uefi.
Comment by Robin Kreis (rkreis) - Tuesday, 13 August 2013, 18:53 GMT
I can confirm this on a Toshiba C850-1K0. Booting the kernel without any parameters from the UEFI shell or Refind simply freezes the system without a single line of output. Booting an older kernel the same way leads to a kernel panic, as expected.

I tested the very same kernel (even verified the sha1sum) on another system using the UEFI shell, and it works just fine there. I predict this may be a tough one.
Comment by ValdikSS (ValdikSS) - Tuesday, 13 August 2013, 18:54 GMT
I have Lenovo X220.
Comment by Jan Steffens (heftig) - Wednesday, 14 August 2013, 00:38 GMT
Duplicate of  FS#33745  .

Loading...