Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#36518 - imagemagick 6.8.6.8-1 --enable-hdri breaks compatibility with rmagick

Attached to Project: Arch Linux
Opened by Latchezar Tzvetkoff (Polizei) - Tuesday, 13 August 2013, 14:58 GMT
Last edited by Eric Belanger (Snowman) - Tuesday, 13 August 2013, 19:46 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Description:

The latest ImageMagick version in `extra' is compiled with `--enable-hdri', which breaks compatibility with RMagick.
After removing the `--enable-hdri' option from the PKGBUILD it all goes back to normal.

Additional info:

* package version(s)
imagemagick 6.8.6.8-1
ruby 2.0.0p247 (2013-06-27 revision 41674) [x86_64-linux]

The Ruby is compiled from source with RVM, but this is not in any case related to the issue.

* config and/or log files etc.

[svn@sh0ckwave(~/redmine)]$ gem install rmagick

Fetching: rmagick-2.13.2.gem (100%)
Building native extensions. This could take a while...
ERROR: Error installing rmagick:
ERROR: Failed to build gem native extension.

/home/svn/.rvm/rubies/ruby-2.0.0-p247/bin/ruby extconf.rb
checking for Ruby version >= 1.8.5... yes
checking for gcc... yes
checking for Magick-config... yes
checking for ImageMagick version >= 6.4.9... yes
checking for HDRI disabled version of ImageMagick... no

Can't install RMagick 2.13.2.
RMagick does not work when ImageMagick is configured for High Dynamic Range Images.
Don't use the --enable-hdri option when configuring ImageMagick.

*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of necessary
libraries and/or headers. Check the mkmf.log file for more details. You may
need configuration options.

Provided configuration options:
--with-opt-dir
--without-opt-dir
--with-opt-include
--without-opt-include=${opt-dir}/include
--with-opt-lib
--without-opt-lib=${opt-dir}/lib
--with-make-prog
--without-make-prog
--srcdir=.
--curdir
--ruby=/home/svn/.rvm/rubies/ruby-2.0.0-p247/bin/ruby


Gem files will remain installed in /home/svn/.rvm/gems/ruby-2.0.0-p247@rails-3.2.13/gems/rmagick-2.13.2 for inspection.
Results logged to /home/svn/.rvm/gems/ruby-2.0.0-p247@rails-3.2.13/gems/rmagick-2.13.2/ext/RMagick/gem_make.out
This task depends upon

Closed by  Eric Belanger (Snowman)
Tuesday, 13 August 2013, 19:46 GMT
Reason for closing:  Won't fix
Additional comments about closing:  rmagick is in AUR which is unsupported. Use ABS to build imagemagick without hdri.

Loading...