Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#36414 - [grub] error: file '/boot/grub/locale/' not found

Attached to Project: Arch Linux
Opened by Oleg Titov (otitov) - Sunday, 04 August 2013, 15:10 GMT
Last edited by Tobias Powalowski (tpowa) - Monday, 05 August 2013, 14:14 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Tobias Powalowski (tpowa)
Ronald van Haren (pressh)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No


I notice now a quick error message during the boot process

error: file '/boot/grub/locale/' not found

then the boot menu is displayed and I can boot arch linux without problem,

when I check the directory /boot/grub/locale/ I see no files, that's why I have this error message,

Additional info:
* package version(s): grub 2.00.5043-2
* config and/or log files etc.: NA

Steps to reproduce:
Boot the system with grub installed, quick error message right before grub's menu appears will be displayed.
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Monday, 05 August 2013, 14:14 GMT
Reason for closing:  Upstream
Additional comments about closing:  This needs to be fixed on grub and is not a packaging bug at all.
Comment by John (graysky) - Sunday, 04 August 2013, 17:14 GMT
The grub wiki page had advice to fix this but it was edited out since I believe the grub package took care of it. Perhaps your experience indicates it is incomplete.

For example:
# mkdir -p /boot/grub/locale
# cp /usr/share/locale/en\@quot/LC_MESSAGES/ /boot/grub/locale/
Comment by Oleg Titov (otitov) - Sunday, 04 August 2013, 19:19 GMT
I have a missing " /boot/grub/locale/", and following this recipe I will produce " /boot/grub/locale/"

So there is no difference between *.mo and *.gmo files?

Comment by mrc (hddnhrst) - Sunday, 04 August 2013, 20:12 GMT
Same error for me, it is '' not found! Same pkg version. I removed the 'locale' dir and had it recreated with grub-install, but that did not help either.
Comment by Tobias Powalowski (tpowa) - Monday, 05 August 2013, 11:43 GMT
I don't think this is a bug, the project just doesn't provide this file.
Nothing is broken for anyone just the message is shown.
Please take this to upstream.
Comment by Tobias Powalowski (tpowa) - Monday, 05 August 2013, 12:01 GMT
<phcoder> tpowa: because there is no "translation team" to English. But English is not the same as "C". E.g. date format differs
<phcoder> tpowa: to solve this problem a set of sed rules is necessary. quot.sed is a good start but it's not complete