Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#36357 - [ffmpeg] when using libswresample

Attached to Project: Arch Linux
Opened by Carlos (cyberconan) - Thursday, 01 August 2013, 10:42 GMT
Last edited by Bartłomiej Piotrowski (Barthalion) - Thursday, 01 August 2013, 20:50 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Bartłomiej Piotrowski (Barthalion)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: When try to resample a dts file to ac3, ffmpeg crash with following error:

ffmpeg: relocation error: ffmpeg: symbol swr_get_class, version LIBSWRESAMPLE_0 not defined in file libswresample.so.0 with link time reference


Additional info:
* package version(s): 2.0

Steps to reproduce:

ffmpeg -i file.dts -acodec ac3 -ac 6 -ab 448k file.ac3

This task depends upon

Closed by  Bartłomiej Piotrowski (Barthalion)
Thursday, 01 August 2013, 20:50 GMT
Reason for closing:  Fixed
Additional comments about closing:  ffmpeg 1:2.0-2
ffmpeg-compat 1:0.10.8-3
Comment by Alejandro Perez (alejandro.perez) - Thursday, 01 August 2013, 11:03 GMT
Same problem here.

ffmpeg -i File.m2t -vcodec mpeg4 -acodec copy -qscale 7 file.avi

Note that not resampling at all.
Comment by Bartłomiej Piotrowski (Barthalion) - Thursday, 01 August 2013, 13:34 GMT
Which architecture do you run?
Comment by Alejandro Perez (alejandro.perez) - Thursday, 01 August 2013, 13:40 GMT
Tested on i686. I could try also on x64, but I rather not upgrade if not required :)

Comment by Bartłomiej Piotrowski (Barthalion) - Thursday, 01 August 2013, 13:46 GMT
I thought so. I suspect that's my fault; I added --disable-asm flag for i686, everything works as expected on x86_64. I will push recompiled package today.
Comment by Alejandro Perez (alejandro.perez) - Thursday, 01 August 2013, 13:47 GMT
That's great, thank you.
Comment by Carlos (cyberconan) - Thursday, 01 August 2013, 13:58 GMT
I have x86_64.

karl@cyberconan ~ % uname -ra
Linux cyberconan 3.10.3-1-ARCH #1 SMP PREEMPT Fri Jul 26 11:26:59 CEST 2013 x86_64 GNU/Linux
karl@cyberconan ~ % ffmpeg -version
ffmpeg version 2.0
built on Jul 11 2013 16:46:25 with gcc 4.8.1 (GCC)
configuration: --prefix=/usr --disable-debug --disable-static --enable-avresample --enable-dxva2 --enable-fontconfig --enable-gpl --enable-libass --enable-libbluray --enable-libfreetype --enable-libgsm --enable-libmodplug --enable-libmp3lame --enable-libopencore_amrnb --enable-libopencore_amrwb --enable-libopenjpeg --enable-libopus --enable-libpulse --enable-librtmp --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libv4l2 --enable-libvorbis --enable-libvpx --enable-libx264 --enable-libxvid --enable-pic --enable-postproc --enable-runtime-cpudetect --enable-shared --enable-vdpau --enable-version3 --enable-x11grab
libavutil 52. 38.100 / 52. 38.100
libavcodec 55. 18.102 / 55. 18.102
libavformat 55. 12.100 / 55. 12.100
libavdevice 55. 3.100 / 55. 3.100
libavfilter 3. 79.101 / 3. 79.101
libavresample 1. 1. 0 / 1. 1. 0
libswscale 2. 3.100 / 2. 1.100
libswresample 0. 17.102 / 0. 6.100
libpostproc 52. 3.100 / 52. 0.100
karl@cyberconan ~ %
Comment by Bartłomiej Piotrowski (Barthalion) - Thursday, 01 August 2013, 14:30 GMT
I'm weak at Google-Fu – could you share a example dts file? Do you have ffmpeg-compat installed? In the meantime please test packages from here[1].

[1] http://pkgbuild.com/~barthalion/tmp/fs36357/
Comment by Bartłomiej Piotrowski (Barthalion) - Thursday, 01 August 2013, 14:32 GMT
Nevermind, found one. Anyway, I'm still unable to reproduce the issue on x86_64.
Comment by Alejandro Perez (alejandro.perez) - Thursday, 01 August 2013, 14:35 GMT
The new package solved the problem for me. Thanks
Comment by Bartłomiej Piotrowski (Barthalion) - Thursday, 01 August 2013, 15:07 GMT
@Carlos: I suppose that ffmpeg-compat is the one to blame. Try to uninstall it and then convert the file again.
Comment by Carlos (cyberconan) - Thursday, 01 August 2013, 15:09 GMT
Problem persist with 64bit test package. The bug is not only with dts files, ffmpeg fail when recompress an ac3 too. (ffmpeg -i file.ac3 -acodec ac3 -ac 6 -ab 448k file-448.ac3).

Then, I have uninstalled ffmpeg-compat and ffmpeg works...
Comment by Alejandro Perez (alejandro.perez) - Thursday, 01 August 2013, 15:20 GMT
Well, I do have ffmpeg-compat installed (it is a dependency for other packages). It works with the test package and ffmpeg-compat installed simultaneously
Comment by Carlos (cyberconan) - Thursday, 01 August 2013, 15:22 GMT
Fine, then the problem could be in ffmpeg-compat for 64bit like Bartłomiej said.

Loading...