Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#36311 - [linux] 3.10.x Intel i3 hangcheck timer hung, corrupted screen

Attached to Project: Arch Linux
Opened by Conley Moorhous (conley) - Sunday, 28 July 2013, 19:09 GMT
Last edited by Tobias Powalowski (tpowa) - Tuesday, 30 July 2013, 10:55 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas Bächler (brain0)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Linux 3.10.3-1
mesa 9.1.5-1
xf86-video-intel 2.21.12-1

The first resume entirely messed up the screen, as shown in the first picture. I had to kill X because I couldn't see a thing.

The second resume (I was testing reproducability this time) flashed between black with corruption (as shown by the second picture) and relatively normal, with small bits of corruption, such as the Chrome tabs (shown in the third picture). It then fixed itself and I am typing this up on it now from the second resume. It sometimes does this NOT during a resume, just in the middle of working.

/var/log/everything.log states:

Jul 28 13:44:13 styrka kernel: [44700.945805] [drm:i915_hangcheck_hung] *ERROR* Hangcheck timer elapsed... GPU hung
Jul 28 13:44:13 styrka kernel: [44700.945818] [drm] capturing error event; look for more information in /sys/kernel/debug/dri/0/i915_error_state

I would attach i915_error_state, but it is larger than 2MB, so here it is on my website (plaintext) http://conleymoorhous.com/i915_error_state and a pastebin http://pastebin.osuosl.org/2743/
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Tuesday, 30 July 2013, 10:55 GMT
Reason for closing:  Fixed
Comment by Conley Moorhous (conley) - Sunday, 28 July 2013, 19:10 GMT
Mixed up the order of the second and third pictures, sorry about that.
Comment by Conley Moorhous (conley) - Tuesday, 30 July 2013, 00:13 GMT
Looks like this could be kernel rather than xf86-video-intel. Truthfully I don't know which part does what.

That being said, I'm still having issues with Linux 3.10.4 and xf86-video-intel 2.21.13 from testing.
Comment by Conley Moorhous (conley) - Tuesday, 30 July 2013, 01:02 GMT
Woke up from suspend to more corruption, as shown in the pictures.

Eventually the system quit responding entirely; nothing would respond at all EXCEPT the mouse. I could move it around fine, but pressing caps lock had no effect, clicking on anything or any keyboard shortcuts naturally had no effect, including trying to switch to a VT. /var/log/everything.log attached.
Comment by Gerardo Exequiel Pozzi (djgera) - Tuesday, 30 July 2013, 02:24 GMT
  • Field changed: Summary (Intel i3 hangcheck timer hung, corrupted screen → [linux] Intel i3 hangcheck timer hung, corrupted screen)
  • Field changed: Status (Unconfirmed → Waiting on Response)
  • Field changed: Category (Packages: Extra → Upstream Bugs)
  • Field changed: Severity (Critical → High)
  • Task assigned to Thomas Bächler (brain0), Tobias Powalowski (tpowa)
Please report to upstream. There is nothing to do here. Thanks.
Comment by Conley Moorhous (conley) - Tuesday, 30 July 2013, 09:58 GMT
Okay, I have e-mailed Chris Wilson of Intel and he reported the following:

"The resume issue is fixed in upstream kernels, though it will be a
3.10.5 at least before it makes it into a release. Graphical corruption
after a hang is to be expected - whatever the GPU was doing at the time
is lost."

In addition, he mentioned that Mesa was likely the cause of my problems, so I'm going to go ahead and try out the git version of mesa -- 9.2 will be released in the next month or so, so I could just use git in the meantime. If I continue to have trouble, I will report to him. Requesting closure. Thanks everyone.

Loading...