Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#36296 - [linux] 3.10.3 reset SuperSpeed USB using xhci_hcd

Attached to Project: Arch Linux
Opened by Adam Kürthy (adee) - Saturday, 27 July 2013, 10:11 GMT
Last edited by Tobias Powalowski (tpowa) - Tuesday, 17 June 2014, 13:46 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas Bächler (brain0)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 14
Private No

Details

Description:
Since the update USB 3 devices stopped working.
Reverting to 3.10.2 makes them working again.

Additional info:
Log attached.
Connecting USB 2 devices seems to work still.
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Tuesday, 17 June 2014, 13:46 GMT
Reason for closing:  Upstream
Comment by Miroslaw Czachor (forest76) - Saturday, 27 July 2013, 13:11 GMT
I have similar problem after 3.10.3 kernel upgrade (usb reset several times, and access to my memorystick reader is slow) but my USB2 devices works with proper speed.

UPDATE: On 3.10.4 (and 3.11-rc1-3) USB system behaviour is the same.
Comment by Serge (Viterzgir) - Saturday, 27 July 2013, 22:46 GMT
I have also such problem with 3.10.3 kernel.
Comment by Alberto Gonzalez (Luis) - Monday, 29 July 2013, 14:15 GMT
Same here, working fine with 3.10.2, but not with 3.10.3.
Comment by Max (homernl82) - Tuesday, 30 July 2013, 09:38 GMT
Same here. Though I did not update quite some time before, so downgrading would be a huge effort. Please fix this soon :)
Comment by Tobias Powalowski (tpowa) - Tuesday, 30 July 2013, 09:56 GMT
Guys report this upstream, I cannot do anything here.
Comment by Alberto Gonzalez (Luis) - Tuesday, 30 July 2013, 10:06 GMT
Yes, this should be reported upstream. There are few commits from 3.10.2 to 3.10.3, so it shouldn't be too difficult to find the culprit. Is anyone here any good at compiling/patching kernels, git-bisecting, etc...? For myself this would be a major pain, so I cannot be so helpful reporting upstream. But if none else here is comfortable with those things either, then I'll do it and do my best to help.
Comment by Alberto Gonzalez (Luis) - Wednesday, 31 July 2013, 18:36 GMT
Ok, it seems the bug is found and there is a patch that fixes it. Should be in the next stable kernel.

http://marc.info/?l=linux-usb&m=137523956310060&w=2
Comment by Mike (teacher4711) - Friday, 02 August 2013, 06:13 GMT
I cannot plug in any usb sticks into my USB2.0 port on 3.10.3. 3.10.4 acts likewise.
The USB sticks are functional after reverting back to 3.10.2.

Output is:
[ 531.920162] end_request: I/O error, dev sdc, sector 0
[ 531.920169] Buffer I/O error on device sdc, logical block 0
[ 531.920256] ldm_validate_partition_table(): Disk read failed.
[ 531.920341] sdc: unable to read partition table
[ 531.958126] sd 8:0:0:0: [sdc] No Caching mode page present
[ 531.958136] sd 8:0:0:0: [sdc] Assuming drive cache: write through
[ 532.066692] usb 5-1: reset full-speed USB device number 3 using uhci_hcd
[ 532.346667] usb 5-1: reset full-speed USB device number 3 using uhci_hcd
[ 532.633344] usb 5-1: reset full-speed USB device number 3 using uhci_hcd
[ 532.916677] usb 5-1: reset full-speed USB device number 3 using uhci_hcd
[ 533.120111] sd 8:0:0:0: [sdc] No Caching mode page present
[ 533.120121] sd 8:0:0:0: [sdc] Assuming drive cache: write through
Comment by Alberto Gonzalez (Luis) - Friday, 02 August 2013, 14:24 GMT
It seems that the patch mentioned above didn't make it into the upcoming 3.10.5:

https://lkml.org/lkml/2013/8/2/298

Would it be possible in this case to just include it in Arch's kernel? So we don't stay 2 weeks with this ugly bug hanging around. Just asking.
Comment by Olivier (olive) - Friday, 09 August 2013, 12:25 GMT
Same problem as Mike (teacher4711) with 3.10.5-1. Usb (2.0) keys (at least some one) do not work. The device file /dev/sdb appears but it cannot be read. Strange enough, my external usb2.0 hard drives seems to work properly. Downgrading to 3.10.2 fix the problem.
Comment by Gwenael (Gwen) - Sunday, 11 August 2013, 10:13 GMT
Same as Olivier here.
Comment by Alberto Gonzalez (Luis) - Sunday, 11 August 2013, 10:19 GMT
For some reason the patch still didn't make it into a stable kernel (3.10.6 won't have it either). Here is the upstream report:

https://bugzilla.kernel.org/show_bug.cgi?id=60664
Comment by Michael Pusterhofer (feanor12) - Sunday, 11 August 2013, 14:16 GMT
Here is a src.tar for building a patched kernel. stock + usb patch
It works for me.
Comment by Andrej Podzimek (andrej) - Friday, 23 May 2014, 04:24 GMT
  • Field changed: Percent Complete (100% → 0%)
The problem is still there in 3.14.4; I haven't seen a USB 3.0 drive work for >6 months. :-(
Comment by Tobias Powalowski (tpowa) - Tuesday, 17 June 2014, 13:45 GMT
Closing this again, the patch mentioned in bug report is upstream, if it is still not working open a new upstream report with your data.

Loading...