Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#36278 - [enchant] Dependencies upon 'hunspell' and 'hspell' are not required

Attached to Project: Arch Linux
Opened by Behnam Momeni (sbmomeni) - Friday, 26 July 2013, 09:53 GMT
Last edited by Jan de Groot (JGC) - Saturday, 27 July 2013, 13:35 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No


The 'hspell' was added in the 'enchant-1.6.0-4' to remove the warning messages about '' file.
An example of this warning message is shown below (printed by 'gedit' program):
** (gedit:3997): WARNING **: Error loading plugin: cannot open shared object file: No such file or directory
Adding 'hspell' as dependency removes that error, but in the wrong way.

The 'enchant' supports 8 backends currently. One of them is 'Hspell' (for hebrew language) which of course is not required by default. The REAL CAUSE of those warning messages is that 'hunspell' was among the dependencies (it prevents 'aspell' to be used).
Removing both 'hunspell' and 'hspell' dependencies eliminates warning messages.

I prepared the 'enchant-1.6.0-5.src.tar.gz' for fixing that bug. It's attached.

Additional info:
* Package enchant-1.6.0-4 is wrongly dependant upon 'hspell'. Attached package 'enchant-1.6.0-5' fixes the bug.
This task depends upon

Closed by  Jan de Groot (JGC)
Saturday, 27 July 2013, 13:35 GMT
Reason for closing:  Not a bug
Additional comments about closing:  hspell is just a small dependency. For Hebrew spellchecking support hspell is required, there's no aspell dictionary for that. I don't want to force hebrew users to rebuild enchant from ABS to support their dictionary.
Comment by Jan de Groot (JGC) - Friday, 26 July 2013, 10:17 GMT
Your bugreport makes no sense. There's several backends in enchant, your package removes hunspell and hspell. Removing the ability to use myspell/hunspell dictionaries and hebrew support makes no sense.
Comment by Behnam Momeni (sbmomeni) - Friday, 26 July 2013, 21:00 GMT
There are several backends for enchant. But this is not a reason for installing all of them by default!!
The only consecuence of installing 'hspell', is a system which instead of 'English', supports 'Hebrew' by default. Users can install packages of all other languages independently (as they wish).
Why should 'enchant' install dictionary packages while it is not dependant upon them?
(dictionary packages need 'enchant' not the vice versa)
Comment by Behnam Momeni (sbmomeni) - Saturday, 27 July 2013, 12:37 GMT
Removing 'hspell' but keeping 'hunspell' fixes the problem too. So I should change my report summary to 'Dependency upon 'hspell' is not required'.
The point is that 'hspell' must not be installed during making the package. The new tarball with 'hunspell' is attached.

With this change 'myspell/hunspell' backend remains enabled.

The 'hspell' was installed during the 'makepkg' (and it was detected by configure script). Making while the 'hspell' is not installed, eliminates (as I see) warning messages about the '' file.

Build Aspell backend: yes
Build Ispell backend: no
Build Uspell backend: no
Build Hspell backend: yes
Build Myspell/Hunspell backend: yes
Build Voikko backend: no
Build Zemberek backend: no
Build a relocatable library: no