Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#36203 - Missing dependency on avahi

Attached to Project: Arch Linux
Opened by Thomas McGrew (mcgrew) - Friday, 19 July 2013, 18:39 GMT
Last edited by Dave Reisner (falconindy) - Sunday, 21 July 2013, 21:42 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Missing dependency on avahi

Additional info:
* package version(s): 4.2.6.p5-15


Steps to reproduce:
Attempting to run ntpd without avahi installed gives the following result

# ntpd -q
ntpd: error while loading shared libraries: libdns_sd.so.1: cannot open shared object file: No such file or directory
This task depends upon

Closed by  Dave Reisner (falconindy)
Sunday, 21 July 2013, 21:42 GMT
Reason for closing:  Works for me
Additional comments about closing:  ntpd doesn't link to avahi
Comment by Dave Reisner (falconindy) - Friday, 19 July 2013, 18:42 GMT
Definitely don't see this dep, not even through ldd.

$ ldd /usr/bin/ntpd
linux-vdso.so.1 (0x00007fff17742000)
libm.so.6 => /usr/lib/libm.so.6 (0x00007f36399e5000)
libcrypto.so.1.0.0 => /usr/lib/libcrypto.so.1.0.0 (0x00007f36395db000)
libcap.so.2 => /usr/lib/libcap.so.2 (0x00007f36393d7000)
libc.so.6 => /usr/lib/libc.so.6 (0x00007f363902a000)
libdl.so.2 => /usr/lib/libdl.so.2 (0x00007f3638e26000)
libz.so.1 => /usr/lib/libz.so.1 (0x00007f3638c0d000)
libattr.so.1 => /usr/lib/libattr.so.1 (0x00007f3638a08000)
/lib64/ld-linux-x86-64.so.2 (0x00007f3639ce3000)

Loading...