Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#36179 - [sdl] compile failure due to change in libx11 > Xlibinit.h : a patch to fix is included

Attached to Project: Arch Linux
Opened by Jeff Meldrum (jspaces) - Wednesday, 17 July 2013, 06:15 GMT
Last edited by Jan Steffens (heftig) - Wednesday, 23 October 2013, 17:24 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan Steffens (heftig)
Architecture All
Severity Very Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description: sdl fails to compile with this error message > SDL_x11sym.h:165:92: error: conflicting types for ‘_XData32’

package version(s) 1.2.15

Steps to reproduce: Download from abs and expect a successful compile.

Fix: After applying the attached patch sdl-1.2.15 compiles successfully.

Steps to correct:

cd "$srcdir/SDL-$pkgver"
patch -p0 < ${srcdir}/sdl_x11sym.patch
This task depends upon

Closed by  Jan Steffens (heftig)
Wednesday, 23 October 2013, 17:24 GMT
Reason for closing:  Fixed
Additional comments about closing:  sdl 1.2.15-4
Comment by Paul Bredbury (brebs) - Thursday, 18 July 2013, 10:07 GMT Comment by Garry Roseman (sitquietly) - Monday, 22 July 2013, 15:58 GMT
The simpler patch from Gentoo is adequate since we do not require backward compatibility with older libx11 -- we just need to compile with libx11-1.6.x.

The patch referred to in comment #1 is a patch to the configure.in file and so requires autoreconf -- but I find that autoreconf fails (because our autotools is too new?).

The patch that works most simply for now is taken from https://bugs.gentoo.org/show_bug.cgi?id=471604, the same as sdl_x11sym.patch given above.




Loading...