Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#3616 - nvidia: failure message needs improvement

Attached to Project: Arch Linux
Opened by Aaron Griffin (phrakture) - Tuesday, 13 December 2005, 16:41 GMT
Last edited by Dale Blount (dale) - Tuesday, 13 December 2005, 19:38 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Tobias Powalowski (tpowa)
Architecture not specified
Severity Medium
Priority Normal
Reported Version 0.7 Wombat
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Hey guys,
Every so often the nvidia installer will fail, and the default scriptlet failure says "X is probably running", but that is not always the case.
The error message should be improved, pointing users to the installer log first, and possibly "tail -n15"-ing the log file. I've seen alot of people saying "but X isn't running and it still tells me to close X".

Just one instance where this came up - the testing kernel was compiled with gcc4.0 when gcc4.1 was released, and an install would fail due to the vermagic not matching (kernel/module versions contain the compiler version too).

Thanks
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Sunday, 18 December 2005, 08:59 GMT
Reason for closing:  Fixed
Comment by Dale Blount (dale) - Tuesday, 13 December 2005, 19:37 GMT
agreed, i've ran into this too.
Comment by Dale Blount (dale) - Tuesday, 13 December 2005, 20:10 GMT
Here's my suggested patch

Loading...