Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#36113 - rxvt-unicode does not display icon because of --disable-pixbuf in PKDBUILD

Attached to Project: Community Packages
Opened by Dirk Sohler (dsohler) - Friday, 12 July 2013, 00:46 GMT
Last edited by Sébastien Luttringer (seblu) - Monday, 05 August 2013, 19:58 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sébastien Luttringer (seblu)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:

Currently installed version 9.18-7 of rxvt-unicode ignores -icon parameter due to being compiled with --disable-pixbuf. -icon is used to display an window icon instead of default icon.

I took the pkgbuild and replaced --disable-pixbuf with --enable-pixbuf and it compiled fine. When testing it, it displayed the icon again.


Additional info:

* version 9.18-7
* [2013-07-06 22:50] [PACMAN] upgraded rxvt-unicode (9.18-5 -> 9.18-7)
* https://projects.archlinux.org/svntogit/community.git/commit/trunk?h=packages/rxvt-unicode&id=086b3125eabf4eed2468538464a541c92e03cc65


Steps to reproduce:

1. try "urxvt -icon youriconfile.png" with 9.18-7
2. opened window has default icon
3. compile as described above
4. try "./rxvt -icon youriconfile.png" with compiled version
5. opened window uses specified icon instead the default icon
Closed by  Sébastien Luttringer (seblu)
Monday, 05 August 2013, 19:58 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#35329 
Comment by Kevin (anonymous_user) - Friday, 12 July 2013, 04:55 GMT
Same as  FS#35329  which was closed as Won't fix.
Comment by Dirk Sohler (dsohler) - Friday, 12 July 2013, 11:38 GMT
Yeah, but just yelling “WONT FIX” does not solve the problem, that without pixbuf neither an own icon nor an own background is possible anymore.
Comment by Kevin (anonymous_user) - Friday, 12 July 2013, 12:51 GMT
Did you also see  FS#34862 ? They removed the gdk-pixbuf2 dependency on purpose. If you don't like this you can either use ABS or one of the custom AUR packages for rxvt-unicode. Also FWIW, someone did upload a rxvt-unicode-pixbuf package but it was later removed.
Comment by Dirk Sohler (dsohler) - Friday, 12 July 2013, 12:55 GMT
Yeah, but removing an important feature is still BS …

Loading...