Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#36111 - Please remove the word 'unofficial' from 'Unofficial Beginners' Guide' link.

Attached to Project: Arch Linux
Opened by Karol Błażewicz (karol) - Thursday, 11 July 2013, 21:14 GMT
Last edited by Dan McGee (toofishes) - Monday, 04 November 2013, 18:20 GMT
Task Type General Gripe
Category Web Sites
Status Closed
Assigned To Dan McGee (toofishes)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

https://www.archlinux.org/ has links to 'Official Installation Guide' and 'Unofficial Beginners' Guide'. We can keep the 'official' part, so we can say: "don't follow some Youtube guide, read the official one in the wiki", but calling Beginners' Guide unofficial is unnecessary.

There used to be a strong division between the official guide maintained in git and the unofficial one maintained directly in the
wiki but now they're both maintained in the wiki so I don't see the need to use the word 'unofficial' anymore.
In a way the whole wiki is unofficial, it's not maintained by the developers, but IMHO stressing that the beginners' guide is unofficial does disservice to the effort.
I guess many (most?) people find the beginners' guide through the wiki main page or through Google, not through the Arch Linux main page, but still I'd like the 'unofficial' part to go.
This task depends upon

Closed by  Dan McGee (toofishes)
Monday, 04 November 2013, 18:20 GMT
Reason for closing:  Fixed
Additional comments about closing:  Done in git.
Comment by Ashley Whetter (AWhetter) - Thursday, 11 July 2013, 21:24 GMT
I agree with this. Yes it's still technically unofficial but the page is of an excellent quality, in my opinion, and the word "unofficial" just doesn't do it justice.
Comment by Sven-Hendrik Haase (Svenstaro) - Thursday, 11 July 2013, 22:05 GMT
I agree, though shouldn't you bring this up on the mailing list rather than on a bug?
Comment by Dario Giovannetti (kynikos) - Friday, 12 July 2013, 11:57 GMT
+1, the Beginners' Guide and the Installation Guide are aimed at two different kinds of readers, they're not in competition and unofficial/official is not what defines the difference between them. Besides, there's not an "Official" Beginners' Guide, so adding "Unofficial" to the only existing Beginners' Guide doesn't make sense.
Comment by Sven-Hendrik Haase (Svenstaro) - Saturday, 13 July 2013, 21:29 GMT
Talk to Eric or Andrea directly, probably we can change this without bureaucracy. Though I still think you should bring this up on the mailing list rather than here.
Comment by Eric Belanger (Snowman) - Saturday, 13 July 2013, 23:46 GMT
The reason for the official vs unofficial is due, in my opinion, to the level of protections for both pages. The official guide can only be edited by users with wiki admin privileges (wiki admins, devs, TUs) so we have total control on what goes on the page. The beginner guide is semi-protected i.e. autoconfirmed users (time passed since account creation and edit count) can edit it. Therefore, pretty much anyone can edit it so you can get in situations like the one discussed here: https://bbs.archlinux.org/viewtopic.php?id=165702
This is probably why it's called unofficial even though it's quite complete and useful.
Comment by Dario Giovannetti (kynikos) - Sunday, 14 July 2013, 05:07 GMT
Counterargument: being "protected" doesn't imply accuracy, the "Official" guide is much less often updated, for example it's still mentioning grub-bios... I'm going to update that now, but the Beginners' Guide was updated almost immediately when grub-bios was replaced.
Anyway we're _not_ discussing whether to remove "Official" from the Installation Guide's link, we're only requesting to remove "Unofficial" from the Beginners' Guide's link, which is not necessary, since like I said the two articles are not in competition with each other.
Comment by Pierre Schmitz (Pierre) - Saturday, 02 November 2013, 22:14 GMT
I find the usage of terms like official and unofficial very difficult in a community driven project anyway. (assigning to Dan as I don't maintain this site and also don't care too much about the wording here)
Comment by Dario Giovannetti (kynikos) - Sunday, 03 November 2013, 05:23 GMT
Here's a patch that also fixes the link to the current "official" Installation Guide article
Comment by Dan McGee (toofishes) - Monday, 04 November 2013, 16:01 GMT
If we're going to patch this, I'd rather remove the word "Official" in the link text itself as well.

* "Official Installation Guide" -> "Installation Guide"
* "Unofficial Beginners' Guide" -> "Beginners' Guide"

I'll take the patch and make this additional change when applying it.

Loading...