Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#36103 - {archweb} Bug links do not show all bugs due to hardcoded category

Attached to Project: Arch Linux
Opened by Ray Rashif (schivmeister) - Thursday, 11 July 2013, 15:26 GMT
Last edited by Eli Schwartz (eschwartz) - Wednesday, 03 January 2018, 17:24 GMT
Task Type Bug Report
Category Web Sites
Status Closed
Assigned To Eli Schwartz (eschwartz)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

The 'Bug Reports' link from a package's details page searches with a bug tracker URL that specifies the 'Packages' category which filters the repository that the package belongs to. This leads to a side-effect where not all bugs are displayed, say, for e.g. if a bug was changed to 'Upstream Bugs'.

A (no longer) current example where this can be seen is opencv. Compare:

https://bugs.archlinux.org/?project=1&cat%5B%5D=2&string=opencv

with:

https://bugs.archlinux.org/?project=1&string=opencv

I believe we don't particularly require the category for bug searches from the web site, since we just search with the name of the package. If it appears in another repo, so be it, but that's better than not showing all existing bugs.

(Attached patch is for demonstration only - I'm not familiar with archweb codebase.)
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Wednesday, 03 January 2018, 17:24 GMT
Reason for closing:  Fixed
Additional comments about closing:  https://git.archlinux.org/archweb.git/co mmit/?id=6ffa5c4957812f3ee584205b6d11ce8 7885f9e6c
Comment by Dan McGee (toofishes) - Wednesday, 11 September 2013, 13:16 GMT
  • Field changed: Summary ({archweb} Bug searches do not show all bugs due to hardcoded category → {flyspray} Bug searches do not show all bugs due to hardcoded category)
  • Field changed: Status (Assigned → Unconfirmed)
  • Assignment removed
This is NOT archweb, please do not tag it as such. Thanks!
Comment by Ray Rashif (schivmeister) - Wednesday, 11 September 2013, 15:29 GMT
Sorry, I wasn't clear -- this has to do with the package details page, nothing flyspray-specific. Some context:

[Wed 10 Jul 2013] [00:15:49] <schiv> hey folks..if i change a bug's category to upstream bugs, will archweb fail to find it (via the bug reports link)?
[Wed 10 Jul 2013] [00:16:38] <schiv> you can check this out by clicking on jack2 in community
[Wed 10 Jul 2013] [00:17:51] <schiv> probably because only packages are selected by default
[Wed 10 Jul 2013] [00:18:00] <schiv> might we want to change that to all categories?
[Wed 10 Jul 2013] [00:31:57] <scarpino> schiv: yes I guess you are right
[Wed 10 Jul 2013] [00:32:36] <scarpino> I see no point in specifying a category
[Wed 10 Jul 2013] [00:33:13] <scarpino> schiv: please send a patch to toofishes
[Wed 10 Jul 2013] [00:35:54] <schiv> ok cool
Comment by Doug Newgard (Scimmia) - Monday, 07 April 2014, 04:18 GMT
  • Field changed: Summary (Bug links do not show all bugs due to hardcoded category → {archweb} Bug links do not show all bugs due to hardcoded category)
  • Field changed: Status (Unconfirmed → Assigned)
  • Task assigned to Dan McGee (toofishes)
The website is what's passing the category to flyspray, how is this NOT archweb?
Comment by Dan McGee (toofishes) - Tuesday, 27 May 2014, 00:42 GMT
Passing no category can easily generate a lot of false positives for some generically named packages.

The goal of the link was so packagers could easily find out if there were open and unaddressed bugs in the package. Given that upstream bugs aren't unaddressed, this is deviating a bit from the intent.

I don't want to bikeshed this, but I'd love to hear a good reason why opening it up makes sense.
Comment by Ray Rashif (schivmeister) - Tuesday, 27 May 2014, 14:14 GMT
There is only one reason and that's bug visibility. Ideally, all bugs should show up, upstream or not. If the occurrence of false positives is significant enough (more trouble viewing than not knowing there are open bugs marked upstream) then it's safe to close this.
Comment by Doug Newgard (Scimmia) - Monday, 06 July 2015, 05:22 GMT
I'd say this either needs acknowledged or closed as "Won't implement" at this point.

Loading...