Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#36093 - pacman PKGBUILD is missing asciidoc makedep

Attached to Project: Arch Linux
Opened by Ashley Whetter (AWhetter) - Wednesday, 10 July 2013, 13:51 GMT
Last edited by Dave Reisner (falconindy) - Wednesday, 10 July 2013, 14:44 GMT
Task Type Bug Report
Category Arch Projects
Status Closed
Assigned To No-one
Architecture All
Severity Very Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
asciidoc is required to build pacman (using the PKGBUILD from abs) but it's not in the makedeps array.
Not having asciidoc installed results in the following:
Making all in doc
GEN pacman.8
GEN makepkg.8
GEN makepkg-template.1
/bin/sh: a2x: command not found

Additional info:
* package version(s)
* config and/or log files etc.
Currently version 4.1.2-1


Steps to reproduce:
copy the pacman directory from /var/abs/core to somewhere where you can build pacman.
Run `makepkg -s` inside the pacman directory
This task depends upon

Closed by  Dave Reisner (falconindy)
Wednesday, 10 July 2013, 14:44 GMT
Reason for closing:  Not a bug
Additional comments about closing:  asciidoc isn't a dependency of the package in [core]
Comment by Dave Reisner (falconindy) - Wednesday, 10 July 2013, 13:54 GMT
This doesn't make sense -- your quoted make output shows makepkg-template, which is only present in pacman-git. We pre-process makefiles so that asciidoc explicitly *isnt* a requirement to build the package in [core].

Loading...