Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#36085 - [abiword] .desktop MimeType entry includes plain text formats like text/plain, xml formats, etc

Attached to Project: Arch Linux
Opened by Marco Scannadinari (zheoffec) - Tuesday, 09 July 2013, 17:00 GMT
Last edited by Jan de Groot (JGC) - Wednesday, 04 May 2016, 13:07 GMT
Task Type General Gripe
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
The .desktop file in /usr/share/applications/' MimeType entry contains various plain text formats not intended for a word processor such as text/plain, text/html, some xml formats, and others which, in the GNOME desktop anyway, causes trouble with filetype associations and their default applications.

Additional info:
* `pacman -Q abiword`:
abiword 2.8.6-9
* `xdg-mime query default text/plain`
abiword.desktop
* Relevant .desktop extract:
"MimeType=application/x-abiword;text/x-abiword;text/x-xml-abiword;text/plain;application/msword;application/rtf;application/vnd.plain;application/xhtml+xml;text/html;application/x-crossmark;application/docbook+xml;application/x-t602;application/vnd.oasis.opendocument.text;application/vnd.oasis.opendocument.text-template;application/vnd.oasis.opendocument.text-web;application/vnd.sun.xml.writer;application/vnd.stardivision.writer;text/vnd.wap.wml;application/wordperfect6;application/wordperfect5.1;application/vnd.wordperfect;application/x-abicollab;"

Steps to reproduce:
`# pacman -S abiword`
This task depends upon

Closed by  Jan de Groot (JGC)
Wednesday, 04 May 2016, 13:07 GMT
Reason for closing:  Won't fix
Additional comments about closing:  abiword can edit text/plain, so it's in mimetypes. This is an issue covered by several other bugreports too, not an abiword issue.
Comment by Matthias Dienstbier (fs4000) - Friday, 12 July 2013, 09:04 GMT
This is related to FS#35528. LibreOffice has this association, too. We should not modify upstream's desktop files but set some sensible default applications.
Comment by Marco Scannadinari (zheoffec) - Saturday, 20 July 2013, 11:52 GMT
Is work being done to resolve this bug or should i report it upstream?
Comment by Giovanni Scafora (giovanni) - Saturday, 20 July 2013, 12:09 GMT
report it upstream
Comment by I Said Socks (socks) - Saturday, 27 July 2013, 06:48 GMT
Heck, even aegisub.desktop includes text/plain in its MimeType list.
My workaround was to blacklist it by putting `text/plain=aegisub.desktop;' under the `[Removed Associations]' section in $XDG_DATA_HOME/applications/mimeapps.lst.
Shipping a default.lst can be a solution, but obviously it's a subjective decision what is good to be the default. I get the feeling Arch Linux packagers are quite reluctant to do such dirty stuff.
Comment by Matthias Dienstbier (fs4000) - Saturday, 27 July 2013, 10:25 GMT
It seems possible to define multiple applications as default for some Mime type. So we could start providing a defaults.list that lists the most common text editors as default for text/plain and file managers for inode/directory. Of course the order would matter, but even that would be better than getting a purely random application.
As a second step we could collect more problematic Mime types and add rules for these. For examples File Roller registers application/x-ms-dos-executable although Wine should probably be the default. It's just useless to open an exe-file as an archive.

I would also be interested in a defaults.list, which makes Gnome applications the default. Same could be done for Xfce and LXDE.
Comment by I Said Socks (socks) - Saturday, 27 July 2013, 11:09 GMT
If we did manage to produce a reasonable defaults.lst, how would you like to ship it? By creaing a new package, say mime-defaults-gnome which would be part of the gnome group maybe? Or is there any existing package suitable to include such a defaults.lst?
For me, I probably wouldn't want a defaults.lst shipped for me, but would rather prefer editting mimeapps.lst myself.
Either way, a nicely compiled mime action list would be very welcome indeed.
Comment by Marco Scannadinari (zheoffec) - Saturday, 27 July 2013, 15:03 GMT
Pushing such a change to the gnome group would be confusing and a bit contraversial because users who dont want it would have to remove it themselves (if they even knew about it), so it would probably be best to package it seperately with a name like socks suggested such as 'mime-defaults-{gnome,kde,xfce,...}
Comment by Alexander F. Rødseth (xyproto) - Monday, 28 October 2013, 12:13 GMT
Auto-extracting zip files are given the .exe extension and file-roller should be able to open them just fine. Someone should probably submit a patch to the file-utility and/or add a new mime extension for .exe files which are really archives. And dosbox, dosemu, wine or virtual machines running DOS or Windows (via some tool) should probably have priority for application/x-ms-dos-executable. Not an easy thing to solve on a package level, since this is really distro-specific. And it's not an easy thing to solve for Arch Linux, since the policy is to keep the default settings as far as that is possible...
Comment by Alexander F. Rødseth (xyproto) - Sunday, 17 November 2013, 18:17 GMT
Assigned to last packager, since abiword is now an orphan.

Loading...