Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#36074 - Repeat pacman info (opt deps and config tips) at the end an update

Attached to Project: Pacman
Opened by bebR (bebR) - Monday, 08 July 2013, 11:45 GMT
Last edited by Dave Reisner (falconindy) - Monday, 08 July 2013, 15:34 GMT
Task Type Feature Request
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
When updating a lot of packages, both optional deps and install information may be lost because of the console scroll.
It would be nice to provide a mechanism to display this information only at the very end of the upgrade.
For example, Gentoo provides a way to do this by using the einfo function from a ebuild script: each einfo displays the message, but it will be displayed again at the end of the process.

This is very convenient to avoid missing any optional deps or crucial information to make a package working correctly.

Additional info:
* pacman, any version


Steps to reproduce:
1. Upgrade a lot of packages
2. Info about optional dependance is readable, but may disappear
3. Important information about configuring/installing a package may also disappear
This task depends upon

Closed by  Dave Reisner (falconindy)
Monday, 08 July 2013, 15:34 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#12861 
Comment by Karol Błażewicz (karol) - Monday, 08 July 2013, 15:28 GMT
Seems like a duplicate of  FS#12861 .
Comment by bebR (bebR) - Monday, 08 July 2013, 15:58 GMT
Sorry I missed that one.
I now understand it's ok to just look at the pacman.log.
Thanks and sorry for that useless ticket! ;)

Loading...