Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#36048 - [ibus] gtk2 immodule cache not updated correctly

Attached to Project: Arch Linux
Opened by Felix Yan (felixonmars) - Saturday, 06 July 2013, 15:44 GMT
Last edited by Ray Rashif (schivmeister) - Saturday, 06 July 2013, 17:48 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Eric Belanger (Snowman)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Since gtk2 2.24.20, the immodules cache path has been changed, and there's new method to update the cache. So one should use

gtk-query-immodules-2.0 --update-cache

instead.

The old way will fail to update the cache and likely to cause ibus not loadable by gtk2 programs.

See also my commit for fcitx-gtk2:
https://projects.archlinux.org/svntogit/community.git/commit/trunk?h=packages/fcitx&id=a497397960ee876bd1ef2d15462b8d996494fa67
This task depends upon

Closed by  Ray Rashif (schivmeister)
Saturday, 06 July 2013, 17:48 GMT
Reason for closing:  Fixed
Additional comments about closing:  See -2 in [extra]
Comment by Felix Yan (felixonmars) - Saturday, 06 July 2013, 15:45 GMT
Oops, sorry I made the title wrong - it should be:

[ibus] gtk2 immodule cache not updated correctly
Comment by Ray Rashif (schivmeister) - Saturday, 06 July 2013, 17:20 GMT
  • Field changed: Summary ([ibus] gtk2 immodule → [ibus] gtk2 immodule cache not updated correctly)
  • Field changed: Status (Unconfirmed → Assigned)
  • Field changed: Severity (Low → Medium)
  • Task assigned to Eric Belanger (Snowman)
Assigning to last packager since package is an orphan.
Comment by Ray Rashif (schivmeister) - Saturday, 06 July 2013, 17:45 GMT
Assigning to last packager since package is an orphan.

Loading...