Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#36047 - xterm 294 accepts input only with mouse over

Attached to Project: Arch Linux
Opened by Michael (hede) - Saturday, 06 July 2013, 14:45 GMT
Last edited by Andreas Radke (AndyRTR) - Sunday, 07 July 2013, 10:15 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture i686
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Updated to upstream xterm 294 (Package: 294-1).

This xterm responds to keyboard inputs only when the mouse is
over/above the xterm window, even the windows itself has still the
focus.
I tried it with lxde and awesome, opened several xterm windows and
switched between them (alt-tab / meta-k). Only if I switch to the xterm
under the mouse position there's any keyboard output.

Downgraded to 293 and everything is fine. AFAIK Arch is using an unpatched upstream xterm so I tried to mail the upstream author (Thomas E. Dickey), but with no success:

554 5.7.1 Service unavailable; Client host [IP] blocked using b.barracudacentral.org;

(it seems the do not like my providers smarthost)

So sorry for writing here, I don't know where else to report this.
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Sunday, 07 July 2013, 10:15 GMT
Reason for closing:  Fixed
Comment by Andreas Radke (AndyRTR) - Saturday, 06 July 2013, 16:40 GMT
I've sent a mail to dickey@his.com pointing him to this report.
Comment by Thomas Dickey (dickey) - Saturday, 06 July 2013, 17:01 GMT
There were only a few changes (assuming that I correctly ifdef'd the code for sixel graphics,
it should not be the cause). There might be some subtle misbehavior from adding the --as-needed
linker option. That is only in the change to plink.sh, and would be the first place I'd look.
(I don't have a copy of arch running to test myself).
Comment by S├ębastien Luttringer (seblu) - Saturday, 06 July 2013, 18:23 GMT
Same issue with i3. The mouse pointer also disapear during typing over the xterm window.
Comment by Thomas Dickey (dickey) - Saturday, 06 July 2013, 18:27 GMT
So... would it be possible for someone to check if reverting the change to plink.sh fixes the problem?
Comment by Bogomil (smirky) - Saturday, 06 July 2013, 20:57 GMT
http://smirky.net/arch/xterm-293-1-x86_64.pkg.tar.xz

Here's a link from my http server for the previous xterm for those who need to rollback.
Comment by Thomas Dickey (dickey) - Saturday, 06 July 2013, 21:02 GMT
I've found a configuration where I can reproduce the problem -
Comment by Thomas Dickey (dickey) - Saturday, 06 July 2013, 22:12 GMT
The quick answer is that reverting the change to plink.sh makes the problem go away,
and also that it's essentially a problem with the X libraries rather than xterm.
I'll do a little investigation to see if I can keep the --as-needed, or simply
revert it.
Comment by Thomas Dickey (dickey) - Sunday, 07 July 2013, 00:00 GMT
The difference between the good/bad executables can be seen using objdump.
Both have the same list of NEEDED records.

In the bad one, the NEEDED records for libXt.so and libX11.so precede the
libXaw.so NEEDED record. In the good one, they are more in the expected
order (libXaw depends on libXt depends on libX11). The misordered records
are present on the older Debian 6 where I do initial development (and xterm
works fine); however the problem can be reproduced on Fedora18 (new, shiny
bleeding-edge).

If the loader is not going to load each shared library completely,
then it is necessary to get the order right - and the X libraries
have some knots in their dependencies that get in the way of that goal.
Comment by Thomas Dickey (dickey) - Sunday, 07 July 2013, 02:10 GMT
I uploaded #295 - adjusting the library order - which works for me.
Comment by Andreas Radke (AndyRTR) - Sunday, 07 July 2013, 08:14 GMT
295 is in extra. Please confirm the fix.

Loading...