Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#36037 - {mirror} New Tier 1 mirrors

Attached to Project: Arch Linux
Opened by Rackspace (rackspace) - Friday, 05 July 2013, 18:11 GMT
Last edited by Dan McGee (toofishes) - Monday, 26 May 2014, 23:54 GMT
Task Type Feature Request
Category Mirrors
Status Closed
Assigned To Dan McGee (toofishes)
Jakob Wadsager (fleet)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

mirror domain name - dfw.mirror.rackspace.com
geographical location - Texas, US
supported protocols - http, rsync
URLs -
http://dfw.mirror.rackspace.com/archlinux
rsync://dfw.mirror.rackspace.com/archlinux
Mirror synced from - rsync://mirror.us.leaseweb.net/archlinux/
email contact - mirroradmin@rackspace.com

mirror domain name - ord.mirror.rackspace.com
geographical location - Chicago, US
supported protocols - http, rsync
URLs -
http://ord.mirror.rackspace.com/archlinux
rsync://ord.mirror.rackspace.com/archlinux
Mirror synced from - rsync://mirror.us.leaseweb.net/archlinux/
email contact - mirroradmin@rackspace.com
This task depends upon

Closed by  Dan McGee (toofishes)
Monday, 26 May 2014, 23:54 GMT
Reason for closing:  Implemented
Comment by Rackspace (rackspace) - Friday, 05 July 2013, 18:18 GMT
mirror domain name - syd.mirror.rackspace.com
geographical location - Sydney, AU
supported protocols - http, rsync
URLs -
http://syd.mirror.rackspace.com/archlinux
rsync://dfw.mirror.rackspace.com/archlinux
Mirror synced from - rsync://mirror.aarnet.edu.au/archlinux/
email contact - mirroradmin@rackspace.com
Comment by Rackspace (rackspace) - Friday, 05 July 2013, 19:13 GMT
mirror domain name - hkg.mirror.rackspace.com
geographical location - Honk Kong, China
supported protocols - http, rsync
URLs -
http://hkg.mirror.rackspace.com/archlinux
rsync://hkg.mirror.rackspace.com/archlinux
Mirror synced from - rsync://rsync.las.ic.unicamp.br/pub/archlinux/
email contact - mirroradmin@rackspace.com
Comment by Jakob Wadsager (fleet) - Saturday, 06 July 2013, 16:28 GMT
I've added these to the database as a tier 2 mirror for now. Tier 1 mirrors sync off rsync.archlinux.org (the mirroring page on the ArchWiki has been corrected).
Comment by Rackspace (rackspace) - Tuesday, 09 July 2013, 12:24 GMT
Hello,

Here is the list of IPs for our current mirrors so that we can change the sync to rsync.archlinux.org:

74.205.112.123 (dfw)
180.150.156.90 (hkg)
166.78.229.128 (ord)
119.9.32.72 (syd)
Comment by Rackspace (rackspace) - Wednesday, 10 July 2013, 12:28 GMT
To additional IPs that will be coming online very soon for additional mirrors will be:

94.236.26.37
72.4.120.22

With those two additions this will complete our 6 DC mirror configuration.
Comment by Jakob Wadsager (fleet) - Sunday, 25 August 2013, 20:00 GMT
The IP's have now been whitelisted.
Comment by Jakob Wadsager (fleet) - Saturday, 31 August 2013, 21:27 GMT
Let me know when the mirrors are syncing from rsync.archlinux.org.
Comment by Rackspace (rackspace) - Wednesday, 30 October 2013, 20:15 GMT
Which module should we be pulling with? We are unable to pull any of the listed modules. We can access rsync.archlinux.org and it gives us a list of modules but doesn't allow us to pull from any of those modules

The issue is the ip should be 72.4.120.222 instead of 72.4.120.22.

You can remove the other white lists as we are using a master pull server now.
Comment by Jakob Wadsager (fleet) - Thursday, 31 October 2013, 03:06 GMT
72.4.120.222 has been whitelisted and the other IP's has been removed.
Comment by Rackspace (rackspace) - Thursday, 31 October 2013, 13:23 GMT
Hello,

This is not working for us.

[root@jenkins ~]# rsync rsync://rsync.archlinux.org/ftp

@ERROR: access denied to ftp from unknown (72.4.120.222)
rsync error: error starting client-server protocol (code 5) at main.c(1503) [receiver=3.0.6]
[root@jenkins ~]# rsync rsync://rsync.archlinux.org/ftp_tier1

@ERROR: access denied to ftp_tier1 from unknown (72.4.120.222)
rsync error: error starting client-server protocol (code 5) at main.c(1503) [receiver=3.0.6]
[root@jenkins ~]# rsync rsync://rsync.archlinux.org/core

@ERROR: access denied to core from unknown (72.4.120.222)
rsync error: error starting client-server protocol (code 5) at main.c(1503) [receiver=3.0.6]
Comment by Rackspace (rackspace) - Friday, 23 May 2014, 14:08 GMT
Hello,

I would like to list an additional mirror, iad.mirror.rackspace.com.

All mirrors are now synced from a single point to ensure the exact same data is on all mirrors and any syncs from upstream that fail do not break the mirrors.

Comment by Dan McGee (toofishes) - Monday, 26 May 2014, 23:53 GMT
Added the new IAD URL for HTTP and rsync protocols. Looks like everything else is working.

Loading...