Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#36034 - [linux] 3.10.0 black screen if hdmi monitor is attached

Attached to Project: Arch Linux
Opened by Uli (Army) - Friday, 05 July 2013, 14:54 GMT
Last edited by Laurent Carlier (lordheavy) - Thursday, 11 July 2013, 16:42 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas B├Ąchler (brain0)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

The system boots to the bootloader, I can select the kernel but then (I guess as soon as radeon is being loaded) the screen becomes black and the system is frozen. Booting without the monitor works fine. Plugging in the monitor after the X-session is started, also freezes the computer.


Additional info:
* package version(s)
linux 3.10-1
xf86-video-ati 1:7.1.0-3
ati-dri 9.1.4-3
libdrm 2.4.46-1
mesa-libgl 9.1.4-3
mesa 9.1.4-3

(don't exactly know which are relevant, the more the merrier)

* config and/or log files etc.

# lspci|grep VGA
00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Wrestler [Radeon HD 6320]

Hard to debug right now, I need a running machine. Will deliver later.


Steps to reproduce:

Plugin in a monitor via hdmi before, during or after booting the machine. The screen will go black not responding anymore.
This task depends upon

Closed by  Laurent Carlier (lordheavy)
Thursday, 11 July 2013, 16:42 GMT
Reason for closing:  Upstream
Comment by Uli (Army) - Saturday, 06 July 2013, 05:24 GMT
Ok, now a bit more precise:

The screen doesn't go black when I plug the monitor being in an X session. That part wasn't precise. Simply plugging it in, nothing happens. But running xrandr to get something onto the htmi monitor causes the freeze. In this case, the laptop screen freezes (but doesn't go black) and nothing happens on the hdmi monitor.

Ok, now some data:

I booted my laptop without the monitor plugged in. Then I ran "sleep 60;systemctl poweroff" and "sleep 30; dmesg > dmesg". After that I ran plugged the hdmi monitor and ran

xrandr --output LVDS --auto --primary --output HDMI-0 --auto --right-of LVDS --output VGA-0 --off

Then, waiting :)

Apparently the system didn't crash, because these command lines worked, I did get a dmesg file and the system shut down.

Here's the end of the dmesg output (the complete dmesg is attached):

[---]
[ 32.321752] wlan0: associated
[ 32.322448] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 33.679231] brcmsmac bcma0:0: brcms_ops_bss_info_changed: arp filtering: 1 addresses (implement)
[ 219.067206] BUG: unable to handle kernel paging request at ffffec2000000900
[ 219.067283] IP: [<ffffffff811716ae>] kfree+0x5e/0x1e0
[ 219.067331] PGD 0
[ 219.067351] Oops: 0000 [#1] PREEMPT SMP
[ 219.067389] Modules linked in: nfnetlink_acct xt_connmark iptable_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_nat_ipv4 nf_nat nf_conntrack iptable_mangle iptable_filter ip_tables x_tables nfnetlink btusb bluetooth ext4 mbcache jbd2 crc16 arc4 brcmsmac snd_usb_audio cordic brcmutil mac80211 cfg80211 uvcvideo snd_usbmidi_lib videobuf2_vmalloc kvm_amd videobuf2_memops videobuf2_core snd_rawmidi snd_seq_device videodev media snd_hda_codec_realtek kvm snd_hda_codec_hdmi eeepc_wmi asus_wmi snd_hda_intel snd_hda_codec sparse_keymap rfkill pci_hotplug snd_hwdep microcode snd_pcm snd_page_alloc snd_timer snd psmouse serio_raw k10temp soundcore i2c_piix4 evdev bcma wmi button battery ac video acpi_cpufreq mperf processor xfs crc32c libcrc32c sha256_ssse3 sha256_generic cbc dm_crypt dm_mod sd_mod ahci libahci xhci_hcd
[ 219.068080] libata ohci_hcd ehci_pci ehci_hcd scsi_mod usbhid usbcore usb_common hid_generic hid radeon i2c_algo_bit drm_kms_helper ttm drm i2c_core
[ 219.068210] CPU: 0 PID: 436 Comm: X Not tainted 3.10.0-1-ARCH #1
[ 219.068255] Hardware name: ASUSTeK Computer INC. 1215B/1215B, BIOS 0401 06/17/2011
[ 219.068309] task: ffff880136757620 ti: ffff880137eec000 task.ti: ffff880137eec000
[ 219.068362] RIP: 0010:[<ffffffff811716ae>] [<ffffffff811716ae>] kfree+0x5e/0x1e0
[ 219.068421] RSP: 0018:ffff880137eed898 EFLAGS: 00010286
[ 219.068460] RAX: 0000022000000900 RBX: 0000100000024414 RCX: 0000000000000000
[ 219.068510] RDX: 000077ff80000000 RSI: 0000000000005fb8 RDI: 0000100000024414
[ 219.068560] RBP: ffff880137eed8e0 R08: 0000000000000013 R09: 0000000000000012
[ 219.068610] R10: 0000000000000000 R11: 0000000000000000 R12: 0000000000000c00
[ 219.068660] R13: ffffec2000000900 R14: 00000003fffffffc R15: ffff880139fe9a00
[ 219.068712] FS: 00007fd270393880(0000) GS:ffff88013ec00000(0000) knlGS:0000000000000000
[ 219.068768] CS: 0010 DS: 0000 ES: 0000 CR0: 000000008005003b
[ 219.068809] CR2: ffffec2000000900 CR3: 0000000137c1c000 CR4: 00000000000007f0
[ 219.068860] DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
[ 219.068910] DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
[ 219.068959] Stack:
[ 219.068976] 000000000000bb80 ffff880137eed8e0 ffff880137eed8e0 ffffffffa002487a
[ 219.069039] ffff880139f0c000 0000000000000c00 0000000000000000 00000003fffffffc
[ 219.069100] ffff880139fe9a00 ffff880137eed9a8 ffffffffa00fd0cb 00007c4800007d2c
[ 219.069161] Call Trace:
[ 219.069203] [<ffffffffa002487a>] ? drm_edid_to_sad+0x1a/0x220 [drm]
[ 219.069271] [<ffffffffa00fd0cb>] evergreen_hdmi_setmode+0x41b/0x6b0 [radeon]
[ 219.069334] [<ffffffffa002506c>] ? drm_detect_hdmi_monitor+0x7c/0xe0 [drm]
[ 219.069399] [<ffffffffa01041b8>] radeon_atom_encoder_mode_set+0x158/0x290 [radeon]
[ 219.069462] [<ffffffffa007e0d2>] drm_crtc_helper_set_mode+0x422/0x450 [drm_kms_helper]
[ 219.069529] [<ffffffffa007f46e>] drm_crtc_helper_set_config+0xa1e/0xb40 [drm_kms_helper]
[ 219.069599] [<ffffffffa001de03>] drm_mode_set_config_internal+0x23/0x50 [drm]
[ 219.069663] [<ffffffffa0020867>] drm_mode_setcrtc+0xf7/0x650 [drm]
[ 219.069720] [<ffffffffa00111e2>] drm_ioctl+0x532/0x660 [drm]
[ 219.069771] [<ffffffff8119c635>] do_vfs_ioctl+0x2e5/0x4d0
[ 219.069813] [<ffffffff8119c8a1>] SyS_ioctl+0x81/0xa0
[ 219.069854] [<ffffffff814d47dd>] system_call_fastpath+0x1a/0x1f
[ 219.069897] Code: 00 00 00 80 ff 77 00 00 49 bd 00 00 00 00 00 ea ff ff 48 01 d8 48 0f 42 15 70 29 6a 00 48 01 d0 48 c1 e8 0c 48 c1 e0 06 49 01 c5 <49> 8b 45 00 f6 c4 80 0f 85 64 01 00 00 49 8b 45 00 a8 80 0f 84
[ 219.070183] RIP [<ffffffff811716ae>] kfree+0x5e/0x1e0
[ 219.070225] RSP <ffff880137eed898>
[ 219.070252] CR2: ffffec2000000900
   dmesg (56.3 KiB)
Comment by Uli (Army) - Saturday, 06 July 2013, 09:21 GMT
Ok, after some more research:

It looks like this is caused by radeon running out of virtual memory. I read that it's likely to be a hardware issue. But it's not in my case, since my laptop runs just fine with linux < 3.10. Looks like a bug in the radeon driver?

I also attached my Xorg.0.log, here's the end of the output

[ 32.652] (II) RADEON(0): EDID vendor "HSD", prod id 1206
[ 32.652] (II) RADEON(0): Printing DDC gathered Modelines:
[ 32.652] (II) RADEON(0): Modeline "1366x768"x0.0 71.90 1366 1414 1480 1486 768 774 782 806 -hsync -vsync (48.4 kHz eP)
[ 198.822] (II) RADEON(0): EDID vendor "HSD", prod id 1206
[ 198.822] (II) RADEON(0): Printing DDC gathered Modelines:
[ 198.822] (II) RADEON(0): Modeline "1366x768"x0.0 71.90 1366 1414 1480 1486 768 774 782 806 -hsync -vsync (48.4 kHz eP)
[ 218.363] (II) RADEON(0): EDID vendor "HSD", prod id 1206
[ 218.364] (II) RADEON(0): Printing DDC gathered Modelines:
[ 218.364] (II) RADEON(0): Modeline "1366x768"x0.0 71.90 1366 1414 1480 1486 768 774 782 806 -hsync -vsync (48.4 kHz eP)
[ 218.460] (II) RADEON(0): EDID vendor "HSD", prod id 1206
[ 218.461] (II) RADEON(0): Printing DDC gathered Modelines:
[ 218.461] (II) RADEON(0): Modeline "1366x768"x0.0 71.90 1366 1414 1480 1486 768 774 782 806 -hsync -vsync (48.4 kHz eP)
[ 218.556] (II) RADEON(0): EDID vendor "HSD", prod id 1206
[ 218.556] (II) RADEON(0): Printing DDC gathered Modelines:
[ 218.556] (II) RADEON(0): Modeline "1366x768"x0.0 71.90 1366 1414 1480 1486 768 774 782 806 -hsync -vsync (48.4 kHz eP)
[ 218.672] (II) RADEON(0): EDID vendor "HSD", prod id 1206
[ 218.672] (II) RADEON(0): Printing DDC gathered Modelines:
[ 218.672] (II) RADEON(0): Modeline "1366x768"x0.0 71.90 1366 1414 1480 1486 768 774 782 806 -hsync -vsync (48.4 kHz eP)
[ 218.761] (II) RADEON(0): Allocate new frame buffer 3286x1088 stride 3296
[ 218.761] (II) RADEON(0): VRAM usage limit set to 337226K

Nothing suspicious there I guess.

I haven't done any configuration limiting the virtual memory.

Here's what lspci -v says about my graphics card

00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Wrestler [Radeon HD 6320] (prog-if 00 [VGA controller])
Subsystem: ASUSTeK Computer Inc. Device 84e3
Flags: bus master, fast devsel, latency 0, IRQ 40
Memory at c0000000 (32-bit, prefetchable) [size=256M]
I/O ports at f000 [size=256]
Memory at feb00000 (32-bit, non-prefetchable) [size=256K]
Expansion ROM at <unassigned> [disabled]
Capabilities: [50] Power Management version 3
Capabilities: [58] Express Root Complex Integrated Endpoint, MSI 00
Capabilities: [a0] MSI: Enable+ Count=1/1 Maskable- 64bit+
Capabilities: [100] Vendor Specific Information: ID=0001 Rev=1 Len=010 <?>
Kernel driver in use: radeon
Kernel modules: radeon

Is there anything else I could provide?
Comment by Laurent Carlier (lordheavy) - Saturday, 06 July 2013, 10:50 GMT
Can you report this bug upstream at http://bugs.freedesktop.org ?
Comment by Frank Phillips (fphillips) - Wednesday, 10 July 2013, 19:46 GMT
Yes, please report upstream or it won't be fixed.

In the meantime, try booting with radeon.audio=0
Comment by Uli (Army) - Wednesday, 10 July 2013, 20:42 GMT
Hi guys, sorry for the delay. I will report it. Just one question: Isn't bugzilla.kernel.org the right bugtracker for this issue?

I'll give radeon.audio=0 a shot.
Comment by Uli (Army) - Thursday, 11 July 2013, 16:37 GMT
Amazing :) I didn't put radeon.audio=0 in the kernel line, but removed that entry completely. Now everything works just fine. So thanks a lot for this hint, I never would have expected, that this could be the reason.
Comment by Laurent Carlier (lordheavy) - Thursday, 11 July 2013, 16:42 GMT
AFAIK it should be fixed for kernel 3.11

Loading...