Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#36025 - [nginx] 1.4.1-3 fails to start with passenger 4.0.5-1

Attached to Project: Community Packages
Opened by Robin Hahling (Rolinh) - Thursday, 04 July 2013, 20:52 GMT
Last edited by Bartłomiej Piotrowski (Barthalion) - Tuesday, 09 July 2013, 07:01 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Bartłomiej Piotrowski (Barthalion)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
Nginx 1.4.1-3 fails to start with passenger 4.0.5-1 when passenger is enabled.


Fix:
A simple nginx package rebuild with passenger 4.0.5 installed fixes the issue as nginx passenger module is built with the nginx package.


Additional info:
* nginx 1.4.1-3
* passenger 4.0.5-1


Steps to reproduce:
* install nginx and passenger
* add this to your nginx.conf file in the http section:
passenger_root /usr/lib/passenger;
passenger_ruby /usr/bin/ruby;
passenger_max_pool_size 10;
* try to start the nginx service
This task depends upon

Closed by  Bartłomiej Piotrowski (Barthalion)
Tuesday, 09 July 2013, 07:01 GMT
Reason for closing:  Fixed
Additional comments about closing:  nginx 1.4.1-4
Comment by Cedric Girard (Xdark) - Monday, 08 July 2013, 16:04 GMT
nginx should be rebuild whenever passenger is updated.
With today update, nginx start but passenger fail with the error "Unable to start the Phusion Passenger watchdog because its executable (/usr/lib/passenger/agents/PassengerWatchdog) does not exist."
Rebuilding nginx from ABS was enough to solve this.

Loading...