Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#36004 - bug in libvdpau and/or libtheora

Attached to Project: Arch Linux
Opened by Alexandre Bolelli Soares (Semeion) - Tuesday, 02 July 2013, 21:52 GMT
Last edited by Laurent Carlier (lordheavy) - Sunday, 07 July 2013, 23:32 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture i686
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 6
Private No

Details

Description:After last pacman -Syu my mplayer2 and flashplugin (firefox/youtube) don´t work anymore.

In last pacman -Syu 3 items have updated:
[2013-07-02 16:11] [PACMAN] upgraded libtheora (1.1.1-2 -> 1.1.1-3)
[2013-07-02 16:11] [PACMAN] upgraded libvdpau (0.6-1 -> 0.6-2)
[2013-07-02 16:11] [PACMAN] upgraded qt4 (4.8.4-18 -> 4.8.5-1)

I think libvdpau and/or libtheora have a bug.

Flash video crashes and mplayer2 don´t open/crash too.

I am using openbox on arch i686.

Additional info:
* package version(s)
* config and/or log files etc.


Steps to reproduce:
Don´t run / don´t open
This task depends upon

Closed by  Laurent Carlier (lordheavy)
Sunday, 07 July 2013, 23:32 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed with mesa-1.9.4-3
Comment by German Thomas (ObliviousGmn) - Tuesday, 02 July 2013, 23:17 GMT
The bug is in libvdpau 0.6-2
Not quite sure what is causing it.

Just downgraded to 0.6-1 and mplayer works perfectly.

Comment by st.binder (nium) - Wednesday, 03 July 2013, 00:01 GMT
same here, downgrade libvdpau solves the problem
Comment by Lukas Fleischer (lfleischer) - Wednesday, 03 July 2013, 00:57 GMT
Same here. The browser uses 100% of my RAM when a flash video is started and gets killed by the OOM killer. Disabling "EnableLinuxHWVideoDecode" in "/etc/adobe/mms.cfg" works, but makes all colors look weird in Flash videos (and sometimes, the browser still crashes -- even if "EnableLinuxHWVideoDecode" is disabled).

Downgrading libvdpau to 0.6-1 works fine here as well.

Maybe this is related to the "Use DRI 2.2 method to determine driver." change in libvdpau 0.6-2 (just guessing)?
Comment by Alexandre Bolelli Soares (Semeion) - Wednesday, 03 July 2013, 03:50 GMT Comment by Lukas Fleischer (lfleischer) - Wednesday, 03 July 2013, 06:38 GMT
Alexandre: Yes...?
Comment by Alexandre Bolelli Soares (Semeion) - Wednesday, 03 July 2013, 08:16 GMT
Lukas, yes, I think the problem is related to the "Use DRI 2.2 method to determine driver" too...


Comment by Jan de Groot (JGC) - Wednesday, 03 July 2013, 08:29 GMT
What drivers do you use, nvidia or something else?

Also, can someone try to recompile 0.6-1, I'm not sure if it's a bug triggered by my last change or the fact that it was recompiled with GCC 4.8.
Comment by Lukas Fleischer (lfleischer) - Wednesday, 03 July 2013, 10:02 GMT
I am using nouveau.

Reverting the makedepends change and recompiling 0.6-2 in a clean chroot fixes the issue (recompiling 0.6-2 with the new dri2proto makedepend doesn't).
Comment by Jan de Groot (JGC) - Thursday, 04 July 2013, 05:35 GMT
Only nouveau so far? Could be a driver bug also then. Deleting the vdpau drivers that come with nouveau-dri should also workaround the crash then.
Comment by Alexandre Bolelli Soares (Semeion) - Thursday, 04 July 2013, 07:24 GMT
I don´t know how delete vdpau drivers that come with nouveau-dri. Deleting /usr/lib/vdpau directory?

Can I do this command?
# pacman -Rdd libvdpau && pacman -U libvdpau-0.6-1-i686.pkg.tar.xz

Will the -Rdd break pacman dependencies integrity?
Comment by Alexandre Bolelli Soares (Semeion) - Thursday, 04 July 2013, 07:32 GMT
They are installed in different places.

https://www.archlinux.org/packages/extra/i686/libvdpau/files/
usr/lib/libvdpau.so
usr/lib/libvdpau.so.1
usr/lib/libvdpau.so.1.0.0

https://www.archlinux.org/packages/extra/i686/nouveau-dri/files/
usr/lib/vdpau/libvdpau_nouveau.so
usr/lib/vdpau/libvdpau_nouveau.so.1
usr/lib/vdpau/libvdpau_nouveau.so.1.0.0
Comment by Gustavo Imago (gustavoimago) - Thursday, 04 July 2013, 12:42 GMT
I am with same problem here, fix it please :)
Comment by Lukas Fleischer (lfleischer) - Thursday, 04 July 2013, 13:00 GMT
Jan: Removing the vdpau drivers that come with nouveau-dri doesn't seem to fix the issue for me.
Comment by Laurent Carlier (lordheavy) - Thursday, 04 July 2013, 13:10 GMT
Works for fine for radeon drivers. Can you try also vdpauinfo from AUR ?

https://aur.archlinux.org/packages/vdpauinfo
Comment by Laurent Carlier (lordheavy) - Thursday, 04 July 2013, 13:48 GMT
Perhaps a matter of firmware. Can you check these pages if it can fix the problems ?

http://nouveau.freedesktop.org/wiki/NVC0_Firmware/
http://nouveau.freedesktop.org/wiki/VP2/
Comment by Dutch de Ruyter (straykat59) - Friday, 05 July 2013, 06:33 GMT
Flashplugin crashes with a segfault from libvdpau.

In dmesg is:
[ 632.725644] plugin-containe[1318]: segfault at e0000009c ip 00007f52d83581a9 sp 00007fff16f29cd0 error 4 in libvdpau_nouveau.so.1.0.

My system is a quad core AMD using x64 Arch with a Nvidia 9800GT using nouveau.
Comment by Jan de Groot (JGC) - Friday, 05 July 2013, 08:23 GMT
Clearly a crash in the nouveau vdpau driver.

Looks like the bug is not in libvdpau at all. The change makes it possible to configure a VDPAU driver trough DRI. Old libvdpau uses nvidia by default and won't use nouveau.

I would like to see some vdpauinfo outputs for people affected. Also, removing the vdpau drivers that are shipped with nouvea-dri should "fix" this problem, if that doesn't work, I would like to see backtraces with debug information.
Comment by Laurent Carlier (lordheavy) - Friday, 05 July 2013, 09:52 GMT
Please test mesa-9.1.4-2 in testing.

vdpau driver is removed from nouveau-dri. Video players should complain about missing vdpau_nouveau driver, but fallback to pure software rendering (tested with vdpau radeon drivers)
Comment by Laurent Carlier (lordheavy) - Friday, 05 July 2013, 09:54 GMT
arghh i've not properly removed it, now it is in mesa!
Comment by Laurent Carlier (lordheavy) - Friday, 05 July 2013, 10:24 GMT
ok, it should be better with mesa-9.1.4-3 in testing
Comment by Dutch de Ruyter (straykat59) - Friday, 05 July 2013, 10:26 GMT
Please find attached my printouts of vdpauinfo from both libvdpau-0.6-1-x86_64.pkg.tar.xz & libvdpau-0.6-2-x86_64.pkg.tar.xz
Comment by Laurent Carlier (lordheavy) - Friday, 05 July 2013, 10:45 GMT
This bug should be reported upstream, it's clearly a vdpau_nouveau driver bug
Comment by Giangi (Rog) - Friday, 05 July 2013, 10:51 GMT
same problem

xf86-video-ati 7.1.0-3
mesa 9.1.4-2

ATI HD5770 Vapor-X
Comment by Laurent Carlier (lordheavy) - Friday, 05 July 2013, 10:58 GMT
@Rog

Any log or backtraces ?
Comment by Dutch de Ruyter (straykat59) - Friday, 05 July 2013, 11:06 GMT
From dmesg:

[11564.438473] plugin-containe[9308]: segfault at 1000000094 ip 00007f95e2f581a9 sp 00007fff4d17a510 error 4 in libvdpau_nouveau.so.1.0.0[7f95e2d5d000+3c1000]
Comment by Giangi (Rog) - Friday, 05 July 2013, 11:07 GMT
@Laurent Carlier (lordheavy)

No crash for me (all work fine) but flashplayer is very slow and a lot of artifacts in multi-tab session (Firefox).
Comment by Laurent Carlier (lordheavy) - Friday, 05 July 2013, 11:09 GMT
@Rog

Not the same problem, please try disabling hardware acceleration in flashplayer
Comment by Lukas Fleischer (lfleischer) - Saturday, 06 July 2013, 17:21 GMT
dwb still crashes occasionally, using mesa 9.1.4-3, nouveau-dri 9.1.4-3 and libvdpau 0.6-2 -- even though it displays "Failed to open VDPAU backend libvdpau_nouveau.so: cannot open shared object file: No such file or directory" on every Flash video. I will try to get a backtrace when it happens next time. Unfortunately, it is much harder to reproduce now (crashed on every video before, only crashes on very few videos now).
Comment by Amit (Etharius) - Saturday, 06 July 2013, 22:58 GMT
I'm currently running the latest version of Nouveau (on an NVIDIA 8600 GT), and I was having the same problems that the OP mentioned with mplayer and flashplugin. Downgrading to libvdpau-0.6-1 has solved my issues.
Comment by Alexandre Bolelli Soares (Semeion) - Sunday, 07 July 2013, 17:30 GMT
Fixed!

Working fine now with nouveau-dri 9.1.4-3 and mesa 9.1.4-3.

No more bugs here, thank you very much! :D
Comment by Lukas Fleischer (lfleischer) - Sunday, 07 July 2013, 22:44 GMT
Ok, looks like the other segfaults are unrelated. They occur even on pages without any embedded Flash.

Loading...