Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#35983 - [libxcb] Build failure: .../install-sh: No such file or directory

Attached to Project: Arch Linux
Opened by Alain Kalker (ackalker) - Sunday, 30 June 2013, 18:11 GMT
Last edited by Jan de Groot (JGC) - Tuesday, 23 July 2013, 11:11 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Andreas Radke (AndyRTR)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Trying to build libxcb, I get the following error:
[...]
Making install in doc
make[1]: Entering directory `/home/miki/pkg/abs/extra/libxcb/src/libxcb-1.9.1/doc'
make[2]: Entering directory `/home/miki/pkg/abs/extra/libxcb/src/libxcb-1.9.1/doc'
make[2]: Nothing to be done for `install-exec-am'.
/bin/sh /home/miki/install-sh -d '/home/miki/pkg/abs/extra/libxcb/pkg/libxcb/usr/share/doc/libxcb'
/bin/sh: /home/miki/install-sh: No such file or directory
make[2]: *** [install-data-local] Error 127
make[2]: Leaving directory `/home/miki/pkg/abs/extra/libxcb/src/libxcb-1.9.1/doc'
make[1]: *** [install-am] Error 2
make[1]: Leaving directory `/home/miki/pkg/abs/extra/libxcb/src/libxcb-1.9.1/doc'
make: *** [install-recursive] Error 1
==> ERROR: A failure occurred in package().
Aborting...

From digging around in the generated configure script, it appears to be related to $ac_aux_dir not being set, which would point to a problem with autoconf.
I get the same error when I manually unpack the tarball and run the commands to patch and build, even in a cleaned environment (`env -i HOME=/home/miki`).

I'm reporting this bug to Arch and not (yet) upstream, because the build documentation for XCB[1] clearly states to use automake 1.7 and autoconf 2.50, and Arch's automake and autoconf are obviously much newer.

[1]: http://xcb.freedesktop.org/DevelopersGuide/

Additional info:
* package version(s)
libxcb 1.9.1-1
automake 1.14-1
autoconf 2.69-1
* config and/or log files etc.


Steps to reproduce:
$ makepkg
This task depends upon

Closed by  Jan de Groot (JGC)
Tuesday, 23 July 2013, 11:11 GMT
Reason for closing:  Fixed
Comment by Alain Kalker (ackalker) - Sunday, 30 June 2013, 18:14 GMT
Well, I misread the "at least" part, maybe I'm going to also report upstream anyway.
Comment by Alain Kalker (ackalker) - Sunday, 30 June 2013, 19:59 GMT
It appears that ordering of initialization of automake was important. I've created a patch and submitted it upstream:
https://bugs.freedesktop.org/show_bug.cgi?id=66413

Loading...