Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#35916 - [linux] Nothing is wrong with checking for lilo.conf

Attached to Project: Arch Linux
Opened by Connor Behan (connorbehan) - Monday, 24 June 2013, 19:35 GMT
Last edited by Tobias Powalowski (tpowa) - Wednesday, 26 June 2013, 08:00 GMT
Task Type Feature Request
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity Very Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: The last edit to linux.install is an overreliance on the fact that people are using official packages. I recommend putting a check back so that people with the /etc/lilo.conf file will see a warning telling them to run lilo after mkinitcpio finishes.
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Wednesday, 26 June 2013, 08:00 GMT
Reason for closing:  Not a bug
Comment by Jan de Groot (JGC) - Monday, 24 June 2013, 20:28 GMT
The last version removes some compatibility symlink checks and a warning for lilo. IMHO lilo users should have migrated years ago to either grub or syslinux.

Anyways, the detection done in the old .install file tries to detect if grub/grub2 is used when lilo.conf is present, but it doesn't take UEFI or syslinux stuff into account.
Comment by Connor Behan (connorbehan) - Wednesday, 26 June 2013, 01:29 GMT
If syslinux needs to be rerun in the same way as lilo, maybe that should be present in the .install file too. If I switch bootloaders it will be to syslinux but "if it ain't broke don't fix it" sentiments have caused me to stick with lilo.
Comment by Tobias Powalowski (tpowa) - Wednesday, 26 June 2013, 08:00 GMT
It doesn't make sense to keep comments on packages that are not included anymore.

Loading...