Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#35897 - [linux] 3.9.7 - 3.10.x Doesn't recognize disconnected graphic card contact

Attached to Project: Arch Linux
Opened by Lex Black (TrialnError) - Saturday, 22 June 2013, 19:50 GMT
Last edited by Tobias Powalowski (tpowa) - Saturday, 05 October 2013, 12:54 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas Bächler (brain0)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Following problem. After upgrading to linux-3.9.7-1 it seems X doesn't start anymore. Downgrading linux to 3.9.6 resolved the problem.
I did further investigate the problem, and curiously no error was printed, if I started an X-server by hand. So I discovered everything works unless the fact I can't switch to the Server. If I try to, the screen freezes and switching back to a tty takes it time.

I narrowed it down to the following problem:
* I have a graphic card with two connectors (nvidia 8800 GTS) (using nouveau)
* I'm using only one of these
* With linux 3.9.7 xrandr aligns both connectors to something. It sees both as connected and active although just one is in use


Additional info:
Some logs:

With Linux 3.9.6:
xrandr message:
xRandr: Found crtc's: 2
xRandr: Linking output DVI-I-1 with crtc 0


Output of xrandr --current:
Screen 0: minimum 320 x 200, current 1680 x 1050, maximum 8192 x 8192
DVI-I-1 connected 1680x1050+0+0 (normal left inverted right x axis y axis) 473mm x 296mm
1680x1050 59.9*+
1400x1050 74.9
1280x1024 75.0
1440x900 75.0 59.9
1152x864 75.0
1024x768 75.1 70.1 60.0
832x624 74.6
800x600 72.2 75.0 60.3 56.2
640x480 72.8 75.0 66.7 60.0
720x400 70.1
DVI-I-2 disconnected (normal left inverted right x axis y axis)


Logs with Linux 3.9.7:
xrandr message:
xRandr: Found crtc's: 2
xRandr: Linking output DVI-I-1 with crtc 0
xRandr: Linking output DVI-I-2 with crtc 1


Output of xrandr --current:
Screen 0: minimum 320 x 200, current 1024 x 768, maximum 8192 x 8192
DVI-I-1 connected 1024x768+0+0 (normal left inverted right x axis y axis) 473mm x 296mm
1680x1050 59.9 +
1400x1050 74.9
1280x1024 75.0
1440x900 75.0 59.9
1152x864 75.0
1024x768 75.1 70.1 60.0*
832x624 74.6
800x600 72.2 75.0 60.3 56.2
640x480 72.8 75.0 66.7 60.0
720x400 70.1
DVI-I-2 connected 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
1024x768 60.0*
800x600 60.3 56.2
848x480 60.0
640x480 59.9

Steps to reproduce:
Dunno.
In my case:
*Have an graphic card with two connectors and use just one of them
*Upgrade to 3.9.7
*Boot and see if you get a X-server session
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Saturday, 05 October 2013, 12:54 GMT
Reason for closing:  Fixed
Additional comments about closing:  3.11.3
Comment by Thomas Bächler (brain0) - Sunday, 23 June 2013, 11:44 GMT
Could be one of these:

commit aed4802d2a0d2f6c7179a2c03e184860741788c0
Author: Ben Skeggs <bskeggs@redhat.com>
Date: Mon Jun 3 16:40:14 2013 +1000

drm/nv50/kms: use dac loadval from vbios, where it's available

commit d40ee48acde16894fb3b241d7e896d5fa84e0f10 upstream.

Regression from merging the old nv50/nvd9 code together, and may be
needed to fully fix fdo#64904.

The value is ignored completely by the hardware starting from nva3.

Reported-by: Emil Velikov <emil.l.velikov@gmail.com>
Signed-off-by: Ben Skeggs <bskeggs@redhat.com>

commit b242745947ed7562ad91dad9e9fde1a92e40d666
Author: Ben Skeggs <bskeggs@redhat.com>
Date: Mon Jun 3 16:07:06 2013 +1000

drm/nv50/disp: force dac power state during load detect

commit ea9197cc323839ef3d5280c0453b2c622caa6bc7 upstream.

fdo#64904

Reported-by: Gerhard Bräunlich <wippbox@gmx.net>
Signed-off-by: Ben Skeggs <bskeggs@redhat.com>

Your problem looks like the second one. Report such bugs upstream please, there is nothing we can do about them.
Comment by Lex Black (TrialnError) - Sunday, 23 June 2013, 16:06 GMT
I posted it on the kernel tracker: https://bugzilla.kernel.org/show_bug.cgi?id=60071

And included your info of what could be the problem
Comment by Tobias Powalowski (tpowa) - Tuesday, 30 July 2013, 10:38 GMT
Status on 3.10.x?
Comment by Lex Black (TrialnError) - Tuesday, 30 July 2013, 23:11 GMT
Issue is still there.
First bug report didn't get any attention, and I opened a new one at the nouveau bug tracker.
https://bugs.freedesktop.org/show_bug.cgi?id=67382

Issue is worked on. (And it was the second commit, which causes the problem)
Comment by Lex Black (TrialnError) - Friday, 23 August 2013, 17:20 GMT
Link to patch (if other people need it and until it will be added to the stable-queue)
https://bugs.freedesktop.org/show_bug.cgi?id=67382#c33
Comment by Tobias Powalowski (tpowa) - Tuesday, 17 September 2013, 08:03 GMT
Status on 3.11.1?
Comment by Lex Black (TrialnError) - Wednesday, 18 September 2013, 19:33 GMT
Dunno if it will be added to 3.11.x

But v2 of the patch was added after the tagging of 3.11 and is included in 3.12-rc1
Comment by Lex Black (TrialnError) - Tuesday, 01 October 2013, 19:21 GMT
The changelog for 3.11.3 mentions the patch so I suppose this can be closed after linux 3.11.3 hits [core]?


Edit: Also fixed in linux-lts 3.10.4

Edit2: Not 3.10.4.. I meant 3.10.14 >.>

Loading...