Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#35868 - [openssl] 1.0.1e-3 fails to build with perl-5.18.0

Attached to Project: Arch Linux
Opened by Garry Roseman (sitquietly) - Thursday, 20 June 2013, 21:13 GMT
Last edited by Pierre Schmitz (Pierre) - Saturday, 02 November 2013, 21:06 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Pierre Schmitz (Pierre)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: the build fails in pod2man while trying to generate man pages from the pod files.


Additional Info:

* config and/or log files etc.

At the end of the build log file we have:

[code]
installing man1/CA.pl.1ssl
installing man1/asn1parse.1ssl
installing man1/ca.1ssl
installing man1/ciphers.1ssl
installing man1/cms.1ssl
cms.pod around line 457: Expected text after =item, not a number
cms.pod around line 461: Expected text after =item, not a number
cms.pod around line 465: Expected text after =item, not a number
cms.pod around line 470: Expected text after =item, not a number
cms.pod around line 474: Expected text after =item, not a number
POD document had syntax errors at /usr/bin/core_perl/pod2man line 71.
make: *** [install_docs] Error 1
[/code]
The input file cms.pod has a simple list of items at the point of failure:

[code]
=item 0

the operation was completely successfully.

=item 1

an error occurred parsing the command options.

=item 2

one of the input files could not be read.
<etc>
[/code]

and pod2man will not accept the "numeric" titles of the items.
I tried putting an =encoding UTF-8 line at the head of this file
but that did not help. Sorry, I don't know how to resolve this.
I have not tried reverting perl to 5.16

Steps to reproduce:

Try to rebuild openssl-1.0.1e-3 on an up-to-date system.
This task depends upon

Closed by  Pierre Schmitz (Pierre)
Saturday, 02 November 2013, 21:06 GMT
Reason for closing:  Fixed
Comment by Garry Roseman (sitquietly) - Thursday, 20 June 2013, 21:22 GMT
Found the patch for fixing this from LFS. I'll test the patch...
Comment by Dave Reisner (falconindy) - Thursday, 20 June 2013, 21:25 GMT Comment by Garry Roseman (sitquietly) - Thursday, 20 June 2013, 21:37 GMT
That patch looks ok. A corrected PKGBUILD is attached.
Comment by Daniel Narvaez (dnarvaez) - Wednesday, 16 October 2013, 14:40 GMT
For what it's worth, the patch works for me.

Loading...