Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#35865 - Gnome 3.8 : unable to change settings using dconf

Attached to Project: Arch Linux
Opened by raymoncal (raymondcal) - Thursday, 20 June 2013, 10:52 GMT
Last edited by Jan de Groot (JGC) - Monday, 15 July 2013, 15:22 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Ionut Biru (wonder)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
Since this morning, all the settings of my Gnome Shell have been reset, and I can’t change them anymore : everytime I check an option in Gnome-control-center, or in the Terminal options, or in Empathy options, the check-mark disappear immediatly, and nothing is saved.
When I’m lauching gnome-control-center via the Terminal, and try to change settings, here is what it says :
(gnome-control-center:2692): dconf-WARNING **: failed to commit changes to dconf: GDBus.Error:org.gtk.GDBus.UnmappedGError.Quark._g_2dfile_2derror_2dquark.Code17: Cannot open dconf database: invalid gvdb header
(systemctl tells that Dbus is running and active)
After googling, it seems to be a bug, related to dconf. Some Fedora’s guys have noticed it too : https://bugzilla.redhat.com/show_bug.cgi?id=975521

Additional info:
* package version(s)
dconf 0.16.0-1
dbus 1.6.12-1

* config and/or log files etc.


Steps to reproduce: Once in Gnome, launch a program that uses dconf to save its settings (typically, gnome-control-center or gnome-terminal) and try to change an option : it won’t be saved, not even will the check-mark stay as you want it to be.
This task depends upon

Closed by  Jan de Groot (JGC)
Monday, 15 July 2013, 15:22 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in latest glib2 package. In testing at this moment.

Note that we can't fix a corrupt database, you'll have to delete it yourself in that case.
Comment by Jan de Groot (JGC) - Thursday, 20 June 2013, 12:33 GMT
Your dconf database is busted because of an unclean shutdown. Probably you can only fix this by deleting the corrupt dconf database and start configuring all over. The redhat bugreport you link says something about a bug in ext4, so the cause of this corruption could be kernel related.
Comment by raymoncal (raymondcal) - Thursday, 20 June 2013, 13:53 GMT
« Probably you can only fix this by deleting the corrupt dconf database and start configuring all over. »
That corrected the bug, thanks.
But this is still a strange behaviour, for I always shut down the correct way…
Comment by Jason Russell (jrussell) - Thursday, 20 June 2013, 20:26 GMT Comment by raymoncal (raymondcal) - Friday, 21 June 2013, 09:37 GMT
Yes, I know this post on the forum – actually, I DID write it…
But reading the Fedora bugreport, I’m pretty sure there is a bug somewhere, with dconf, or ext4…
By the way : I’m sure I _didn’t_ shutdown uncleanly.
Comment by Jan de Groot (JGC) - Friday, 12 July 2013, 08:01 GMT
It's a bug in glib2 which has been fixed upstream in git. Guess you're running ext4 on LVM or something like that?

Loading...