Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#35842 - [kdebindings-python] synaptiks doesn't run after recent split of python packages

Attached to Project: Arch Linux
Opened by phanisvara das (phani00) - Tuesday, 18 June 2013, 08:26 GMT
Last edited by Andrea Scarpino (BaSh) - Tuesday, 18 June 2013, 12:21 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andrea Scarpino (BaSh)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

after pyqt-common, pyqt, and python2-pyqt were replaced by their respective ~qt4 packages, synaptiks from [community] fails to start with the following error (the same happens with the synaptiks-git package from AUR):

[phani@laptop ~]$ synaptiks
Traceback (most recent call last):
File "/usr/bin/synaptiks", line 9, in <module>
load_entry_point('synaptiks==0.8.1', 'gui_scripts', 'synaptiks')()
File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 343, in load_entry_point
return get_distribution(dist).load_entry_point(group, name)
File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2354, in load_entry_point
return ep.load()
File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2060, in load
entry = __import__(self.module_name, globals(),globals(), ['__name__'])
File "/usr/lib/python2.7/site-packages/synaptiks/kde/__init__.py", line 39, in <module>
from PyKDE4.kdecore import KAboutData, ki18nc
RuntimeError: the sip module implements API v10.0 but the PyKDE4.kdecore module requires API v9.2
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Tuesday, 18 June 2013, 12:21 GMT
Reason for closing:  Fixed
Additional comments about closing:  kdebindings-python2 4.10.4-2
Comment by Andrea Scarpino (BaSh) - Tuesday, 18 June 2013, 10:32 GMT
Please try with kdebindings-python2 4.10.4-2
Comment by phanisvara das (phani00) - Tuesday, 18 June 2013, 12:00 GMT
works great, thank you.

Loading...