Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#35829 - [wget] ABS build fails

Attached to Project: Arch Linux
Opened by Darshit Shah (darnir) - Monday, 17 June 2013, 08:25 GMT
Last edited by Eric Belanger (Snowman) - Sunday, 29 September 2013, 17:26 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Eric Belanger (Snowman)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
Build fails on an updated system for the ABS PKGBUILD. This happens due to the updates Perl packages that breaks the texi2pod script int he tarball.

Even though Perl happens to cause make to fail, the problem is actually supposed to be a warning, not an error. And running make a second time works just fine.

I have reported this issue upstream too but it seems unlikely that it will be patched soon since most of them are not facing this issue, yet. Could we maybe help them in patching it?

One solution is to substitute the make command in the PKGBUILD with "make || make". Forcing make to run a second time which will end successfully.

Additional info:
* Wget 1.14
* Relevant Output:
Making all in doc
make[2]: Entering directory `/home/sauron/builds/wget/src/wget-1.14/doc'
./texi2pod.pl -D VERSION="1.14" ./wget.texi wget.pod
/usr/bin/core_perl/pod2man --center="GNU Wget" --release="GNU Wget 1.14" wget.pod > wget.1
wget.pod around line 2105: Expected text after =item, not a number
wget.pod around line 2110: Expected text after =item, not a number
wget.pod around line 2116: Expected text after =item, not a number
wget.pod around line 2121: Expected text after =item, not a number
wget.pod around line 2126: Expected text after =item, not a number
wget.pod around line 2131: Expected text after =item, not a number
wget.pod around line 2136: Expected text after =item, not a number
wget.pod around line 2141: Expected text after =item, not a number
POD document had syntax errors at /usr/bin/core_perl/pod2man line 71.
make[2]: *** [wget.1] Error 255


Steps to reproduce:
Copy the ABS Sources from the ABS tree to a local directory
Run makepkg
This task depends upon

Closed by  Eric Belanger (Snowman)
Sunday, 29 September 2013, 17:26 GMT
Reason for closing:  Fixed
Additional comments about closing:  wget-1.14-3
Comment by Dave Reisner (falconindy) - Monday, 17 June 2013, 17:23 GMT
Not necessarily the correct way to do this, but the attached patch WFM.
Comment by Darshit Shah (darnir) - Monday, 17 June 2013, 17:29 GMT
Works for now! Thanks! I am hopeless with Perl, but just out of curiosity could you please explain this?
Comment by Dave Reisner (falconindy) - Monday, 17 June 2013, 17:33 GMT
I don't know Perl either. Fortunately, It has less to do with Perl and a lot more to do with POD formatting. Wrapping the =item parameter in C<> forces the string to be not strictly numeric, and passes whatever wonky validation is in place. C<> implies code markup, similar to B<> for bold, I<> for italic, etc.
Comment by Dave Reisner (falconindy) - Monday, 17 June 2013, 17:41 GMT
Also, I wouldn't rule this out as being a regression in perl 5.18. The doc isn't very clear about what's acceptable after =item except to say "be consistent".
Comment by Darshit Shah (darnir) - Monday, 17 June 2013, 17:56 GMT
I wouldn't be so sure of a regression, since it seems like this check was deliberately added. See: https://github.com/theory/pod-simple/commit/5a01eba83824d9f91ecfae302af33fef65a8385c

The suggested workaround is to either wrap it in C<>s or prepend a Z<>, etc. I'll also submit this patch upstream with many thanks!
Comment by Florian Pritz (bluewind) - Monday, 17 June 2013, 18:05 GMT Comment by Florian Pritz (bluewind) - Saturday, 24 August 2013, 20:11 GMT
Forgot to mention this:

I've heared back from Schwern. He said he didn't follow up on that closed bug report, but we could try asking on pod-people[1].

[1]: http://lists.perl.org/list/pod-people.html

Loading...